使用高级工具 > 关于自定义函数 > 使用自定义函数
 

使用自定义函数

注释  选中"使用高级工具"常规首选项时,可以使用此功能。请参阅使用高级工具

要创建自定义函数:

1. 选择"文件"菜单 >"管理">"自定义函数"。

2. 在"管理自定义函数"对话框中,单击"新建"。

3. 在"编辑自定义函数"对话框中,为"函数名"键入新函数的名称。

自定义函数的名称必须是唯一的,并且不能超过 100 个字符。

4. 生成公式

请参阅使用公式和函数

5. 如果公式需要参数,请在"函数参数"中,键入参数名称并单击"添加"双箭头控件。您可以编辑或删除参数名称,方法是在列表中选择参数名称,然后单击"编辑"添加按钮 或"删除"删除按钮

6. 单击希望项目在公式框中出现的位置,然后执行以下操作之一。

 

要添加

请执行此操作

参数引用

在参数列表中,双击某个参数名称。

数学或文本运算符

在键盘中,单击某个运算符。

比较或逻辑运算符

对于"运算符",请从列表中选择一个运算符。

常数值

键入值。

函数

在函数列表中,双击某个函数。在公式框中,用值或表达式替换占位符参数。

也可以在"编辑自定义函数"对话框中键入参数名称、运算符和函数,而不是使用列表或键盘输入。

7. "所有帐户"是"可用性"的默认选项,允许当前数据库的所有用户查看和使用自定义函数。如果希望自定义函数仅对享有完全访问权限的用户可用,请选择"仅限具备完全访问权限的帐户"。

8. 单击"确定",关闭"编辑自定义函数"对话框。

9. 继续创建自定义函数,或单击"确定",关闭"管理自定义函数"对话框。

要更改、复制或删除自定义函数:

1. 选择"文件"菜单 >"管理">"自定义函数"。

2. 在"管理自定义函数"对话框中:

 

目的

请执行此操作

编辑自定义函数

在"函数名"中,选择自定义函数并单击"编辑"。在"编辑自定义函数"对话框中进行更改,然后单击"确定"。

复制自定义函数

在"函数名"中,选择自定义函数并单击"复制"。

删除自定义函数

在"函数名"中,选择自定义函数并单击"删除"。

3. 在"管理自定义函数"对话框中,单击"确定"。

要将自定义函数拷贝到其他 FileMaker Pro Advanced 文件:

1. 选择"文件"菜单 >"管理">"自定义函数"。

2. 在"管理自定义函数"对话框中,选择一个或多个要拷贝的函数。

提示 您可以按住 Ctrl 键并单击 (Windows) 或按住 Command 键并单击 (macOS) 来选择非连续函数,或按住 Shift 键并单击来选择连续函数。

3. 按 Ctrl+C (Windows) 或 Command-C (macOS) 以拷贝函数,然后单击"确定"。

提示 macOS:您可以选择"文件"菜单 >"拷贝"来拷贝所选函数。

4. 打开其他 FileMaker Pro Advanced 文件。

5. 选择"文件"菜单 >"管理">"自定义函数"。

6. 按 Ctrl+V (Windows) 或 Command-V (macOS) 以粘贴函数。

提示 macOS:您可以选择"文件"菜单 >"粘贴"来粘贴所选函数。

您所拷贝的自定义函数会显示在列表的底部。如果 FileMaker Pro Advanced 确定此函数在目标文件的上下文中为无效(例如,目标文件缺少所依赖的函数、字段或计算,或者函数包含无效字段类型参考),会将已粘贴的函数加上注释字符 (/*<function_definition>*/)。请参阅自定义函数依赖性规则

7. 单击"确定"。

注释 

您必须具有当前活动数据库的"完全访问"权限才能创建自定义函数。

即使自定义函数被设置为对所有具备完全访问权限的用户可用,其内容也会受到保护。要编辑或查看自定义函数的内容,必须拥有"完全访问"权限。

如果您不具备"完全访问"权限并且试图编辑的计算使用了受限于"完全访问"帐户的自定义函数,那么您将看到字符串"<专用函数>"而不是自定义函数本身。只要公式中出现 <专用函数> 的声明,就不能更改该计算。

如果以前已创建自定义函数,并且其名称与新的 FileMaker 软件函数相同,则 FileMaker 函数会替代您的自定义函数。根据 FileMaker 函数验证您的自定义函数名称,并按需要更改自定义函数名称。

相关主题 

函数参考(类别列表)

函数参考(按字母顺序排序的列表)