参考 > 键盘快捷方式 (macOS) > 模式键盘快捷方式 (macOS)
 

模式键盘快捷方式 (macOS)

可以在 FileMaker Pro Advanced 模式中工作时使用以下键盘快捷方式。

 

要切换至

按键

浏览模式

命令-B

查找模式

命令-F

布局模式

命令-L

预览模式

命令-U

浏览模式键盘快捷方式

可以使用浏览模式下的键盘快捷方式来创建、删除、复制、省略、排序和打印记录

 

目的

按键

创建记录

命令-N

复制记录

命令-D

删除记录

命令-E

删除记录且不做确认

命令-Option-E

修改上次查找条件

命令-R

显示所有记录

命令-J

对记录排序

命令-S

转到下一条记录

请参阅导航键盘快捷方式

转到上一条记录

请参阅导航键盘快捷方式

转到特定记录

Esc(激活当前记录编号框),键入记录编号,然后按 Enter 键

省略记录

命令-T

省略多个记录

命令-Shift-T

为活动字段打开或关闭下拉列表或日历

Esc

为活动字段打开或关闭弹出菜单

空格键

打印记录

命令-P

在不显示对话框的情况下打印记录

命令-Option-P

刷新窗口

命令-Shift-R

激活快速查找框

命令-Option-F

打开"替换字段内容"对话框(选择字段时)

命令- =

查找模式键盘快捷方式

可以使用查找模式下的键盘快捷方式来创建和复制查找请求

 

目的

按键

选择/取消选择"省略"按钮

命令-T

创建查找请求

命令-N

删除查找请求

命令-E

复制查找请求

命令-D

显示所有记录

命令-J

执行查找请求

Enter(当脚本被暂停时禁止)

粘贴来自索引的信息

命令-I

转到下一个查找请求

请参阅导航键盘快捷方式

转到上一个查找请求

请参阅导航键盘快捷方式

转到特定的查找请求

Esc(激活当前请求编号框),键入请求编号,然后按 Enter 键

布局模式键盘快捷方式

在布局模式下,可以使用键盘快捷方式来排列和对齐对象、格式化字段、控制布局工具,以及创建布局。

布局创建与导航

 

目的

按键

创建新布局

命令-N

转到下一个布局

请参阅导航键盘快捷方式

转到上一个布局

请参阅导航键盘快捷方式

转到特定布局

Esc(激活当前布局编号框),键入布局编号,然后按 Enter 键

对象选择与修改键盘快捷方式

 

目的

按键

选择布局上的对象

重复按 Tab 键或 Shift-Tab 直至选中所需的对象。

选择多个对象

按住 Shift 键的同时分别单击各个对象。

注释  您也可以拖动箭头指针来用选择框包含对象。选择框不必完全包围对象。(要仅选择被包围在选择框中的对象,请在拖动时按住 命令。)

检查器打开时调整所选对象的大小

命令-1 会移至"检查器"的"定位"命令 选项卡。用 Tab 键切换所需的大小调整操作,然后按 Return。

调整选定对象的大小并保持其比例不变

按住 Shift 键并拖动手柄。

调整多个对象的大小并保持其长度或宽度差不变。

按住 Option-Shift 并拖动手柄

在调整对象大小时,对象的相对边缘将保持固定在相同位置。

拷贝所选对象的样式

命令-Option-C

粘贴另一个对象的样式

命令-Option-V

对象对齐键盘快捷方式

 

目的

按键

左对齐

命令-Option-向左键

右对齐

命令-Option-向右键

靠上对齐

命令-Option-向上键

靠下对齐

命令-Option-向下键

显示或隐藏标尺

命令-Option-Shift-R

显示或隐藏对象网格

命令-Option-Y

在调整对象大小时,关闭网格、参考线并动态参考线的对齐效果

按住 命令 拖动对象手柄

在拖动对象时,关闭网格、参考线并动态参考线的对齐效果

命令 同时拖动该对象

将对齐对象切换到网格

命令-Option-Shift-Y

创建或编辑对象时显示或隐藏参考线

命令-Option-;

将对齐对象切换到参考线

命令-Option-Shift-;

创建或编辑对象时切换动态参考线

命令-Option-'(撇号)

对象排列键盘快捷方式

 

目的

按键

使所选对象向前景移动

命令-Shift-[

将所选对象移至最上层

命令-Option-[

部分标签从水平改为垂直,或从垂直改为水平

命令,然后单击标签

拖动选定的布局部分越过对象

按住 Option 并拖动部分

复制所选对象

命令-D

通过拖动来复制对象

按住 Option 并拖动对象

组合对象

命令-R

锁定对象

命令-Option-L

将所选对象移动 1 磅(如果设置为磅或英寸)或 0.1 厘米(如果设置为厘米)

箭头键

使用箭头键使所选对象移动 10 倍远

Shift-箭头键

对所选部分重新排序

按住 Shift 并拖动部分

旋转对象

命令-Option-R

将所选对象向背景移动

命令-Shift-]

将对象置于底层

命令-Option-]

拆分对象

命令-Shift-R

解除对象的锁定

命令-Shift-Option-L

检查器键盘快捷方式

 

目的

按键

显示或隐藏检查器

命令-I

显示检查器的"定位"命令 选项卡

命令-1

显示检查器的"样式"命令 选项卡

命令-2

显示检查器的"外观"命令 选项卡

命令-3

显示检查器的"数据"命令 选项卡

命令-4

"字段"选项卡(布局模式)键盘快捷方式

 

目的

按键

打开字段选项卡

命令-K

在"字段"选项卡中添加新字段

命令-Return 或 命令-Enter

对选定字段重命名

Return 或 Enter

"对象"选项卡键盘快捷方式

 

目的

按键

显示或隐藏对象选项卡

命令-Option-T

布局工具键盘快捷方式

 

目的

按键

将当前工具与"选择"工具相互切换

Enter 键或 Shift-Enter(数字键盘)
Fn-Enter 或 Fn-Shift-Enter(适用于没有数字键盘的计算机)

使用"线"工具画一条水平或垂直的线

绘制线条的同时按 Shift

使用"线"工具以 45 度增量画线

绘制线条的同时按 Option

仅水平或仅垂直移动对象

移动对象时按住 Shift 键

使用"椭圆形"工具画圆

画圆的同时按 Option

使用"矩形"工具画正方形

画正方形的同时按 Option

仅限以正方形或圆形的比例调整对象大小

调整对象大小时按住 Option