保存、导入和导出数据 > 将数据导入 FileMaker Pro Advanced > 将数据导入到现有文件
 

将数据导入到现有文件

可以从其他 FileMaker Pro Advanced 文件或从其他应用程序创建的文件中将数据导入到现有 FileMaker Pro Advanced 文件。导入的记录将成为搜索结果。导入时,可以添加新记录、更新匹配记录或替换现有记录。

提示 如果您定期从同一个源导入数据,则可以通过设置重复性导入来自动执行该过程。通过重复性导入而导入的数据在 FileMaker Pro Advanced 中是只读的。请参阅设置重复性导入

本主题介绍了如何从 FileMaker Pro Advanced 支持的文件格式中导入数据。要从其他数据源进行导入,请参阅以下主题:

 

要导入

参考资料

同时导入包含图像文件的文件夹或文本文件

同时导入文件夹中的多个文件

XML 数据

导入 XML 数据

ODBC 数据

查询来自 FileMaker Pro Advanced 的 ODBC 数据源

要将数据导入到现有文件:

1. 在源应用程序(即包含需要导入到 FileMaker Pro Advanced 中的数据的应用程序)中,以 FileMaker Pro Advanced 支持的文件类型保存要导入的数据。

有关受支持的文件类型列表,请参阅支持的导入/导出文件格式

2. 如果要更新现有或匹配记录,请为导入操作的目标 FileMaker Pro Advanced 文件创建一个备份副本。

重要事项  更新匹配记录或替换现有记录会改写目标文件中的数据,并且无法撤消。要保护您的数据,请选择"文件"菜单 >"另存为"以创建目标 FileMaker Pro Advanced 文件的备份副本。只能对本地文件(位于您计算机上的文件)执行此操作。请确保您了解更新或替换记录的工作方式。请参阅将数据导入 FileMaker Pro Advanced

3. 如果要从 FileMaker Pro Advanced 文件中导入记录并要导入特定记录而省略其他记录,请打开该文件,然后执行查找,以便当前窗口中的搜索结果只包含您要导入的记录。

请参阅查找记录。FileMaker Pro Advanced 决定要从源文件前景窗口导入的搜索结果。如果从已关闭的文件或未在任何窗口中显示的打开文件中导入记录,将导入所有记录,而不考虑任何搜索结果。

4. 打开要向其中导入记录的 FileMaker Pro Advanced 文件(目标文件)。

5. 如果目标文件包含多个表,请使用"布局"弹出菜单来显示数据导入目标表中的布局

布局不必显示表中的所有字段。您可以在"导入字段映射"对话框中指定要导入的字段。

6. 如果要更新匹配记录或替换现有记录,请在导入前执行以下操作。(如果要添加新记录,请跳到下一步。)

如果要更新匹配记录,请确保搜索结果仅包含要更新的记录。即使匹配字段的数据相匹配,搜索结果外的记录也不会被更新。

如果要替换文件中的现有记录,请确保搜索结果中只包含要更改的记录。如有必要,请对记录进行排序,以便源文件中的正确记录替换目标文件中每条记录的数据。

7. 选择"文件"菜单 >"导入记录">"文件"。

8. 在"打开文件"对话框中,对于"文件类型"(Windows) 或"显示"(macOS),选择要导入的文件的类型。或者,选择"所有文件"以查看当前文件夹中可以导入的所有文件。

9. 选择文件,然后单击"打开"。

如果要从包含多个工作表或包含指定范围的 Microsoft Excel 文件中导入数据,您将看到"指定 Excel 数据"对话框。选择要导入的工作表或指定范围,然后单击"确定"。

如果要从自定义分隔值文件导入,您将看到"指定字段分隔符"对话框。从列表中选择字符(或选择"其他"并键入字符)以分隔源文件中的字段值。然后选择文件扩展名为 .tab 或 .txt 的文件(必要时重命名源文件)。

10. 在"导入字段映射"对话框中,单击 匹配目标字段图标,然后选择要执行的导入操作。

请参阅将数据导入到现有文件的方法

11. 选择一个目标表:

 

要将数据导入到

对于"目标",选择

现有表

当前表或表名称

新表

新表

有关将数据导入到新表的更多信息,请参阅关于为导入数据创建新表

12. 将目标文件中的字段映射到您要从源文件导入的数据,然后单击"导入"。

有关使用"导入字段映射"对话框以及完成导入过程的详细信息,请参阅在导入过程中设置导入操作和映射字段

相关主题 

支持的导入/导出文件格式

对记录排序

记录脚本步骤