添加和查看数据 > 处理表视图中的数据
 

处理表视图中的数据

查看表视图中的记录时,FileMaker Pro Advanced 会像电子表格中一样按行和列显示数据。每行显示一条记录,每列显示一个字段

处理字段

当您在浏览模式下的"表视图"中查看数据时,可以创建、修改或删除字段。

注释  您必须通过"完全访问权限"权限集登录以修改"表视图"中的字段。

 

目的

请执行此操作

创建字段

针对第一个字段,单击表中第一个列的列标题中的"创建字段"。要创建其他字段,请单击列标题中的"+"。

要取消创建新字段,请在提交更改之前按"Esc"。

您可以通过取消选择"首选项"对话框中的"将新定义的字段添加到当前布局中",来防止创建的新字段自动放置在当前布局中。请参阅设置布局首选项

更改字段名称

双击要重命名字段的列标题,然后键入新名称。

要丢弃对字段名称的更改,请在退出列标题之前按"Esc"。

提示  可以按 Tab 键或 Shift-Tab 键编辑字段名。如果按最右边列标题中的 Tab 键,则 FileMaker Pro Advanced 创建新列。

选择字段类型

右键单击列标题,选择"字段">"字段类型"显示快捷菜单,并选择一种字段类型。

设置字段选项

右键单击列标题,然后选择"字段">"字段选项"。请参阅设置字段的选项

通过一个或多个字段对记录排序

选择列标题,还可以选择按住 Ctrl 键并单击 (Windows) 或按住 Command 键并单击 (macOS) 其他标题。右键单击其中一个选定的列标题并选择"升序排序"或"降序排序"。列标题上将出现一个排序图标,指示排序设置。

如果您选择多个列,则选择列的顺序将确定排序顺序。

从多字段排序顺序中删除字段

选择一个不排序标题取消选择排序依据的列,然后右键单击要从排序顺序中删除的标题,并选择"从排序中删除 <字段名>"。

按预定义值列表对记录排序

选择任何列标题,右键单击,然后选择"按值列表排序",并选择值列表。

从排序顺序中删除一个或多个字段并重新排序

按照两个或多个字段对文件排序,选择然后右键单击要从排序顺序中删除的列标题,选择"从排序中删除 <字段名>"。数据将根据排序顺序中保留的字段重新排序。

提示  单击状态工具栏中的"排序"可查看当前排序顺序。

取消文件排序

右键单击排序文件中的任何列标题并选择"取消排序"。

显示更多字段或隐藏字段

单击布局栏中的"修改",并使用"修改表视图"对话框中的选项。请参阅在"表视图"中显示和隐藏字段

或右键单击列标题,然后选择"字段">"隐藏字段"以隐藏选定字段。要在"表视图"中显示隐藏字段,右键单击"+"列标题,然后从现有字段列表中选择字段。

删除字段

右键单击列标题,然后选择"字段">"删除字段"。请参阅删除表定义、字段定义和数据

处理记录

 

目的

在浏览模式下执行此操作

添加新记录

在表底部的空白记录中,输入数据。单击表底部的左边距中的 显示视频文件图标的容器字段。将新行添加在表的末尾:

如果记录尚未排序

或者

如果"对记录排序"对话框中的"将记录按照排序顺序保存"已清除

若为已排序数据,一个新行将添加到当前所选行已排序类别的最后一行。

复制记录

右键单击所要复制记录的左边距或右边距,然后选择"复制记录"。

拷贝记录中的数据

右键单击所要拷贝记录的左边距或右边距,然后选择"拷贝记录"。可以粘贴拷贝的、以制表符分隔的数据。

删除记录

右键单击所要删除记录的左边距或右边距,然后选择"删除记录"。

一次删除多条记录

可以切换到查找模式,找到要删除的记录,然后选择"记录"菜单 >"删除已找到的记录",然后单击"全部删除"。请参阅创建查找请求

对记录排序

右键单击记录的左边距或右边距,然后选择"对记录排序"。使用"对记录排序"对话框指定如何对记录排序。请参阅对记录排序的选项

设置"表视图"的显示选项

 

目的

在浏览模式下执行此操作

对列重新排序

将列标题拖动到新位置。

设置精确的列宽

选择一个或多个列标题。右键单击,然后从快捷菜单中选择"表视图">"设置列宽"。

编辑"表视图"属性

右键单击列标题或者右边距或左边距,并选择"表视图">"编辑属性"。

更改背景颜色

右键单击记录的左边距或右边距,从快捷菜单中选择"部分颜色",然后选择一种颜色。添加新记录的行和添加新字段的列颜色比主背景颜色略深。

为交替记录显示不同背景颜色

右键单击记录的左边距或右边距,然后从"更换颜色"快捷菜单中选择颜色。如果自定义颜色或用图像填充该部分,则该部分已锁定。

创建动态报表

请参阅在"表视图"中创建动态报表

恢复默认显示设置

右键单击列标题或者左边距或右边距并从快捷菜单中选择"表视图">"重置"。

注释  重置"表视图"仅会更改表的外观设置。例如,它删除所有前置和后置小计,并填充您添加到表中的颜色。重置表不会对数据造成任何影响。

注释 

要在"表视图"中对数据进行重新排序、调整大小或排序,您可以选择多列,但无法选择多个单元格。

"表视图"显示当前布局正文部分中的字段。如果布局包括一个显示相关表的记录的入口,"表视图"显示第一条相关记录(入口第一行)中的数据。

您可以编辑表的任何一行中的全局字段。请参阅定义全局字段(具有全局存储的字段)

相关主题 

创建快速图表

关于命名字段

关于选择字段类型