使用脚本自动执行任务 > 创建并编辑脚本
 

创建并编辑脚本

注释  有关每个脚本步骤及其选项和示例的信息,请参阅脚本步骤参考(按字母顺序排序的列表)脚本步骤参考(类别列表)。另请参阅脚本示例

要创建或编辑脚本:

1. 选择"脚本"菜单 >"脚本工作区"。

或者,选择"文件"菜单 >"管理">"脚本"。

随即会打开"脚本工作区"。使用此窗口中的三个面板创建和编辑脚本 - 脚本面板(左)、脚本编辑面板(中)和脚本步骤面板(右)。

2. 创建或打开脚本:

要创建脚本,请单击 帮助按钮。在脚本编辑面板中,键入新脚本的名称,然后按 Enter 键或 Return 键。

要预览脚本,在脚本面板中单击脚本名称。单击 计算方式按钮 可从预览脚本切换为编辑脚本。

要编辑脚本,在脚本面板中双击脚本名称。如果已在脚本编辑面板中打开脚本,单击脚本的选项卡将其激活。

3. 开始键入脚本步骤名称,然后从出现的列表中选择脚本步骤。

或者,在脚本步骤面板中双击脚本步骤。

4. 如果脚本步骤包含选项 - 由方括号中包含的文本 ([ ]) 或脚本步骤旁的 操作菜单按钮 指示,请执行以下操作之一:

单击方括号中的文本,然后指定出现的选项。

单击 操作菜单按钮,然后指定出现的选项。

单击方括号之间,然后编辑算式,或者单击 类别排序按钮 打开"指定计算方式"对话框。只有一些算式可内联编辑。

注释  编辑脚本步骤时,可能会看到"恢复"选项。恢复指示在执行脚本步骤时,会使用上次编辑脚本步骤时所指定的条件。

5. 在脚本编辑面板中工作时,执行下列任意操作:

 

目的

请执行此操作

向脚本添加一行

执行以下某项操作:

按 Enter 键或 Return 键。

如果脚本的最后一行不是空行,则选择最后一行并按下向下键。

在所选行上方添加一行

按 Shift+Enter 键或 Shift-Return 键。

在脚本中的行间移动

按向上键或向下键。

向脚本添加注释

在空行上,键入 # 或从脚本步骤面板中选择"注释"。在脚本中使用 # (注释)脚本步骤可以帮助他人查看或修改脚本。

向"个人收藏"类别添加脚本步骤

在脚本步骤面板中,选择脚本步骤并单击 管理脚本菜单按钮。要从"个人收藏"类别中删除脚本步骤,请选择脚本步骤并单击 灰色星形按钮

注释  如果脚本步骤面板按字母顺序排序,则无法向"个人收藏"类别添加脚本步骤。

查看关于脚本步骤的信息

在脚本步骤面板中,单击脚本步骤。说明即会出现在列表的下面。要查看更多信息,请单击 “兼容性”按钮

按字母顺序或按类别查看脚本步骤

在脚本步骤面板中,单击 运行脚本按钮 按字母顺序显示脚本步骤,或单击 管理脚本菜单按钮 按类别列出。

查看哪些 FileMaker 产品支持脚本步骤

单击 新建文件夹按钮 并选择产品。将显示与该产品兼容的所有脚本步骤。

拷贝并粘贴脚本步骤

请参阅拷贝并粘贴脚本

复制脚本步骤

选择脚本步骤,然后选择"编辑"菜单 >"复制"(Windows) 或"复制步骤"(macOS)。

删除脚本步骤

选择脚本步骤,然后按 Delete 键。

重新排序脚本中的脚本步骤

将脚本编辑面板中的脚本步骤拖到脚本中的新位置。

选择多个脚本步骤

按住 Ctrl 键并单击 (Windows) 或按住 Command 键并单击 (macOS)。可以添加、复制或删除多个步骤。

打开包含在脚本步骤选项中的脚本。

按住 Ctrl 键并单击 (Windows) 或按住 Command 键并单击 (macOS) 脚本步骤选项。

运行脚本

单击 “兼容性”按钮

注释  脚本名称旁边的星号 (*) 表示脚本已更改但未保存。

6. 关闭选项卡,然后单击"保存"。

或者,在"脚本工作区"中选择"文件"菜单 >"保存脚本"(Windows),或在 FileMaker Pro Advanced 菜单栏中选择"脚本"菜单 >"保存脚本"(macOS)。

要管理脚本:

 

目的

请执行此操作

重命名、复制或删除菜单

右键单击脚本名称,然后从菜单中选择。您还可以在脚本编辑面板中单击脚本名称两次以重命名脚本。

重新排序脚本

将文件名拖到列表中新的位置。

打印脚本

Windows:在"脚本工作区"中,选择"文件"菜单 >"打印脚本"。

macOS:在 FileMaker Pro Advanced 菜单栏中,选择"文件"菜单 >"打印"。

完全访问权限执行脚本

右键单击脚本并选择"授予完全访问权限"。请参阅下面的"以完全访问权限运行脚本"。

管理脚本面板中的文件夹

请参阅使用文件夹管理脚本

以完全访问权限运行脚本

将脚本设置为以完全访问权限运行允许具有有限访问权和权限的用户可以执行通常情况下无法执行的脚本任务,如导出或删除记录。

访问权限不会变化,但脚本被允许的权限高于用户权限。而且,除非在该脚本中启用此功能,否则完全访问不会应用到后续的子脚本中。

脚本可设置为只有具有完全访问权限集的用户才能以完全访问权限运行。只有具有完全访问权限的用户才可以编辑或删除启用此功能的脚本。

脚本只能在定义该脚本的文件中以完全访问权限运行。脚本不能覆盖外部文件上的访问限制。例如,设置为以完全访问权限运行的脚本不能删除有访问限制的外部文件中的记录。

可以授予没有完全访问权限的用户对在所分配权限集中标记为可修改的脚本的编辑权限。创建、复制、导入和/或删除这些脚本则要求完全访问权限。

注释 

要在生成脚本时检查问题,右键单击脚本编辑面板中的选项卡并选择检查问题。FileMaker Pro Advanced 会检查脚本并突出显示有问题(如缺少选项)的行。(并非每个问题都能检测到。)这些行会在"脚本工作区"首选项的"语法着色"选项卡中以默认的问题颜色突出显示。

要编辑脚本步骤和条件(如问题)的颜色编码,在"脚本工作区"中,选择"查看"菜单 >"首选项"(Windows) 或"查看"菜单 >"脚本工作区首选项"(macOS) 并单击"语法着色"选项卡。

要在新窗口中编辑脚本,右键单击脚本编辑窗格中的选项卡并选择"将选项卡移动到新窗口",或者按 Alt (Windows) 或 Option (macOS) 并双击脚本窗格中的脚本。脚本在"编辑脚本"对话框中打开。

要允许脚本以完全访问权限运行,选择"文件"菜单 >"授予完全访问权限"(Windows) 或"脚本"菜单 >"授予完全访问权限"(macOS)。

如果通过将按钮操作转换为脚本来访问"编辑脚本"对话框,可以按 Ctrl+R 键 (Windows) 或 Command-R 键 (macOS) 重命名脚本。

相关主题 

在公式中使用运算符

脚本步骤参考(类别列表)

脚本步骤参考(按字母顺序排序的列表)

使用布局上的按钮和按钮栏

使用脚本菜单

编辑脚本权限

在 Web 上发布数据库

调试脚本

禁止脚本步骤