保存、导入和导出数据 > 将数据文件转换为新的 FileMaker Pro Advanced 文件
 

将数据文件转换为新的 FileMaker Pro Advanced 文件

可以将其他应用程序中的数据文件转换为新的 FileMaker Pro Advanced 文件。FileMaker Pro Advanced 导入数据并创建新的 FileMaker Pro Advanced 文件。这个转换后的文件将包含:

转换的文件或数据源中的数据。

用于显示数据的两种布局:标准表单布局列表视图布局

转换的字段名(如果转换的文件或数据源中提供了字段名)。否则,字段名是普通的:f1、f2、f3 等。(字段名从 Microsoft Excel、FileMaker Pro、逗号分隔值、自定义分隔值、DBF、Merge、ODBC 和 XML 格式转换。)

已转换的字段类型,如文本、数值、日期等(如果转换的文件或数据源中提供了这些字段类型)。否则,所有字段都是文本字段。(字段类型从 FileMaker Pro、Microsoft Excel、ODBC、DBF 和 XML 格式转换。)

有关将数据导入到现有文件中的信息,请参阅将数据导入到现有文件

要将数据导入到新文件:

1. 在源应用程序(即包含需要导入到 FileMaker Pro Advanced 中的数据的应用程序)中,以 FileMaker Pro Advanced 支持的文件类型保存要导入的数据。

请参阅支持的导入/导出文件格式

2. 在 FileMaker Pro Advanced 中,选择"文件"菜单 >"新建",然后双击"转换"。

或使用以下某个方法打开数据文件:

选择文件菜单 >打开,然后继续下一步。

将数据文件拖到 FileMaker Pro Advanced 应用程序图标上,并跳至步骤 4

3. 在"打开文件"对话框中,对于"文件类型"(Windows) 或"显示"(macOS),选择文件的类型(如果需要)。找到要转换的文件,然后选择文件并单击"打开"。

4. 如果要转换 Microsoft Excel 电子表格并且出现"指定 Excel 数据"对话框,请从工作簿文件中选择一个工作表或指定范围,然后单击"确定"。

5. 在"另存为"对话框中,为新文件键入名称,选择一个位置,然后单击"保存"。

6. 在"转换文件"对话框中,如果您要导入的源数据中的记录包含字段名称(列标题)而不是数据,请单击 自动输入选项图标前进箭头 直到包含字段名称的记录出现。然后选择"用作字段名称"。

只有后续记录可用于导入。目标字段名称现在与源中的相同。

7. 在列表中每对字段之间的"映射"列中,单击当前映射,然后选择是否从源文件中的每个字段导入数据。

8. 对于"目标",指定要将数据导入的表的名称。

9. 在"导入选项"区域中,根据需要选择字符集和字段分隔符选项。

参阅在导入过程中设置导入操作和映射字段中的步骤 9

10. 单击"转换"。

注释 

如果要导入的文件很大,则可能看到显示导入过程进度的"导入"对话框。要停止导入,请单击"停止"。但 FileMaker Pro Advanced 仍将创建包含部分已转换数据的文件。

如果您定期从同一个源导入数据,则可以通过设置重复性导入来自动执行该过程。通过重复性导入而导入的数据在 FileMaker Pro Advanced 中是只读的。请参阅设置重复性导入