添加和查看数据 > 拼写检查
 

拼写检查

FileMaker Pro Advanced 可以检查下列位置的文字拼写:

字段中选中的字或段落

只检查当前记录中的可见字段(包括任何相关字段)

当前搜索结果中所有记录的可见字段(包括任何相关字段)

布局模式下,当前布局中的所有文本对象(包括不在最上层的选项卡面板滑动面板上的任何文本对象)

可以设置 FileMaker Pro Advanced 在键入时进行拼写检查,或在已编辑的文本中使用红点下划线指示可能的拼写错误。在"文件选项"对话框的"拼写"选项卡上可以设置这些选项。请参阅设置文件选项

默认情况下,FileMaker Pro Advanced 会逐个字段地检查拼写。要禁用各个字段的拼写检查,在检查器的"数据"发音为“heisei”的日本语汉字字符 选项卡的"行为"区域选择"不要应用可视拼写检查"。

进行拼写检查时,FileMaker Pro Advanced 会将文本与两个字典比较,即主字典和用户字典。主字典预设为使用本地语言(例如,在美国为 usenglsh.mpr)。您不能编辑主字典,但可以将其更改为其他语言。主字典始终可以使用。

FileMaker Pro Advanced 包括下列语言的拼写字典:荷兰语、法语、意大利语、德语、葡萄牙语(巴西)、葡萄牙语(葡萄牙)、西班牙语、瑞典语、瑞士德语、英国英语、美国英语和美国英语(医药)。

用户字典 user.upr 是第二个字典,也是可编辑的字典。可以创建多个用户字典,但是一次只能使用一个。可以在任意时间更改用户字典,或完全关闭用户字典,只使用主字典。

要在当前字段、记录、搜索结果或布局中检查拼写:

1. 显示记录或布局,找到记录集,或选择要检查的文本。

2. 选择"编辑"菜单 >"拼写",然后选择拼写命令。

3. 如果"单词"框中出现有问题的单词,请选择一个选项。

注释  不能更改受限或受密码保护文件或字段中的单词。在这种情况下,单击"下一步"。

 

目的

请执行此操作

使用字典中的单词替换错拼单词

选择列表中的建议,然后单击"替换"。

修改拼写字典中没有的错拼单词

对于"",键入替换单词。如果要验证新单词的拼写,请单击"查看",否则单击"替换"。

保持单词原样不动

单击"全部忽略"。将跳过该单词的每个匹配项。

保持单词原样不动,并将其添加到用户字典

单击"了解"。

注释  编辑用户字典之前必须选择该用户字典(参阅下文)。

4. 完成拼写检查时,单击"完成"。

注释  无法在 Web 查看器合计字段容器字段中检查拼写。

要使用拼写字典:

要创建、选择和编辑拼写字典,请选择"编辑"菜单 >"拼写">"选择字典",然后选择一个选项并单击"确定"。

要编辑、导出或导入用户字典,请选择"编辑"菜单 >"拼写">"编辑用户字典",然后选择一个选项并单击"确定"。