创建和管理布局及报表 > 使用布局上的弹出框 > 添加弹出框
 

添加弹出框

可以向布局中添加弹出框以组织对象,并使数据输入更加简单。要向布局中添加弹出框,请创建弹出框按钮。FileMaker Pro Advanced 会同时创建一个弹出框。在弹出框上添加字段和其他布局对象。

要向布局中添加弹出框:

1. 布局模式下,从"布局"弹出菜单中选择所需的布局。

2. 状态工具栏中:

Windows:单击"按钮工具"“移到上一个面板”按钮 或"弹出框按钮工具"“移到下一个面板”按钮 旁边的箭头,然后从菜单中选择"弹出框按钮"。然后,拖动十字线绘制弹出框按钮。

macOS:单击并按住"按钮工具 “移到上一个面板”按钮"或"弹出框按钮工具 “移到下一个面板”按钮",然后从菜单中选择"弹出框按钮"。然后,拖动十字线绘制弹出框按钮。

布局上显示弹出框按钮连同弹出框。

3. 在"弹出框按钮设置"对话框中,选择您希望标签显示的方式。

默认情况下,FileMaker Pro Advanced 创建居中对齐的仅文本标签。请参阅定义或更改按钮

4. 选择弹出框的其他选项,包括选择弹出框打开的方向、更改弹出框的标题以及显示标题栏。

请参阅更改弹出框设置

5. 要向弹出框分配一个或多个脚本触发器,请单击"设置脚本触发器"并选择一个或多个脚本触发器。

请参阅设置脚本触发器使用脚本自动执行任务

6. 要向弹出框添加对象,请选择弹出框。如果弹出框未显示,请选择"格式"菜单 >"显示弹出框"。要添加对象,请使用状态工具栏中的布局工具,从"插入"菜单中选择项目,或者将对象拖动到弹出框上。

7. 单击关闭按钮关闭弹出框。

注释 

您可以将弹出框放置在入口内,但是,不能在位于入口内的弹出框上放置入口。

Windows:在浏览模式下,弹出框不能显示在 Web 查看器或交互容器的前面。为避免这些对象重叠,如果可能,弹出框将缩小,或显示在这些对象的后面。

可以从弹出框上的字段中导出数据,以下情况例外:

以 Excel 格式保存或发送数据(使用"文件"菜单 >"将记录保存/发送为">"Excel")时,弹出框上的字段将不会包括在目标文件中。改为使用"文件"菜单 >"导出记录"。命名目标文件和设置 Excel 选项后,在"导出"对话框中的"指定字段顺序"中选择"当前表",然后选择要导出的字段。请参阅从 FileMaker Pro Advanced 中导出数据

使用"表视图"中的上下文菜单拷贝记录或以 PDF 格式保存或发送记录时,弹出框上的字段将不会包括在目标文件中。

当您使用拷贝记录/请求脚本步骤拷贝所有记录/请求脚本步骤时,弹出框上的字段不包括在目标文件中。

如果脚本步骤指定的字段位于弹出框中,则弹出框会打开且该字段被选定。如果相同字段出现在布局上的其他位置,并且该脚本首先找到了该字段,那么带有相同字段的弹出框将不会出现。相反,为字段分配一个对象名,并使用转到对象脚本步骤移到字段的该实例。

弹出框按钮在布局模式中由标记 字段/控件工具 标识。如果没有看到标记,请选择"查看"菜单 >"显示">"弹出框按钮"。

相关主题 

设置按钮、弹出框按钮和弹出框的格式

设置布局对象的自动调整大小选项