作業を自動化するためのスクリプトの作成 > スクリプトの作成と編集 > フォルダを使用したスクリプトの管理
 

フォルダを使用したスクリプトの管理

1. [スクリプト] メニュー > [スクリプトワークスペース...] を選択します。または [ファイル] メニュー > [管理] > [スクリプト...] を選択します。

2. スクリプトパネルで、目的のタスクを実行します。

 

目的

操作

新しいスクリプトフォルダの作成

スクリプトパネルで、新規フォルダの上に表示されるスクリプト名またはフォルダを選択します。アクションメニューボタン をクリックするか、[ファイル] メニュー > [新規フォルダ] (Windows) または [スクリプト] メニュー > [新規フォルダ] (macOS) を選択します。

スクリプトパネルの現在の位置に新規フォルダが表示され、[スクリプト] メニューのサブメニューとして表示されます。

フォルダの名前を変更する

名前を変更するフォルダを右クリックして、[名前変更] を選択します。新しい名前を入力して Enter キー (Windows) または return キー (macOS) を押します。

フォルダおよび含まれているすべてのスクリプトを複製する

フォルダを右クリックして、[複製] を選択します。

フォルダおよび含まれているすべてのスクリプトを削除する

フォルダを右クリックして、[削除] を選択します。

フォルダを別のファイルにコピー、貼り付け (ペースト) する

スクリプトのコピーと貼り付け (ペースト) を参照してください。

フォルダを展開/折りたたむ

次のいずれかの操作を行います:

フォルダ名の左側にある矢印をクリックします。

フォルダを選択して、右向矢印キーまたは左向矢印キーを押します。

フォルダをダブルクリックします。

メモ  すべてのフォルダを展開または折りたたむには、Ctrl キー (Windows) または command キー (macOS) を押しながらフォルダ名の左側にある矢印をクリックします。

スクリプトをフォルダ内に移動する

フォルダを展開します (上記参照)。スクリプト名をクリックして、展開したフォルダの下または展開したフォルダ内にドラッグします。スクリプトは、[スクリプト] メニュー内のフォルダのサブメニューにも表示されます。

スクリプトの一覧を名前でフィルタする

スクリプトパネルの検索ボックスにスクリプト名 (またはその一部) を入力します。

同時に複数のスクリプトを編集する

スクリプトパネルで、編集するそれぞれのスクリプトをダブルクリックします。スクリプト編集パネルで、各スクリプトのタブが個別に開きます。

3. スクリプトメニューにフォルダを含めるには、フォルダの隣にあるチェックボックスを選択するか、フォルダを右クリックして [スクリプトメニューに含める] を選択します。

スクリプトパネルでスクリプト名およびフォルダの左側にチェックボックスを表示するには、[新規区切り線] ボタン をクリックします。

メモ  チェックボックスを選択すると、フォルダの下にあるスクリプトではなく、フォルダだけが含まれます。サブメニューに表示するフォルダ下のスクリプトの横にあるチェックボックスを選択します。