オブジェクト、レイアウトパート、およびレイアウト背景の編集 > レイアウトの書式設定 > ボタン、ポップオーバーボタン、およびポップオーバーの書式設定
 

ボタン、ポップオーバーボタン、およびポップオーバーの書式設定

ボタンまたはポップオーバーボタンの書式を設定するには、次の操作を行います。

1. レイアウトモードで、ボタンまたはポップオーバーボタンを選択します。

2. インスペクタ外観 外観 タブをクリックします。

3. [ボタン] または [ボタン: アイコン] をオブジェクトタイプの一覧 ([外観] タブの上部近く) で選択し、次の操作を行います。

メモ  コンポーネントによっては、一部のオプションは使用できません。

 

目的

操作

線のスタイル、色、塗りつぶし属性を変更する

[グラフィック] 領域の線のスタイル、色、塗りつぶしオプションを選択します。

ラベルテキストの書式を変更する

次のいずれかの操作を行います:

インスペクタの [テキスト] 領域でオプションを選択します。

書式設定バーでテキストオプションを使用します。書式設定バーが表示されていない場合は、レイアウトバー書式設定 データ をクリックします。

ラベルテキストとアイコンの縦と横の配置を設定する

[段落設定] 領域で、縦と横の配置を設定します。

ラベルアイコンの色を変更する

オブジェクトタイプの一覧で [ボタン: アイコン] を選択し、表示状態 (タブの 2 番目の一覧) を選択します。[グラフィック] 領域で色を選択します。

アイコンの塗りつぶし色を変更できます。ただし SVG 形式のカスタムアイコンでは、FileMaker Pro Advanced で塗りつぶしの設定を変更すると、SVG ファイルで塗りつぶしの色が設定されていない要素のみが影響されます。SVG のサポートの詳細については、FileMaker Pro SVG Grammar for Button Icons (英語) を参照してください。PNG 形式のカスタムアイコンの塗りつぶし色は変更できません。

オブジェクトの表示状態の指定を参照してください。

影を追加する

[詳細なグラフィック] 領域で [外側の影]、[内側の影]、またはその両方を選択します。

ボタンの端同士の間、およびラベルテキストとアイコンの間のパディングを調整する

[詳細なグラフィック] 領域の [パディング] で、[]、[]、[]、[] の値をポイント単位で指定します。

アイコンとラベルテキストの間のパディングを調整する

オブジェクトタイプの一覧で [ボタン: アイコン] を選択し、パディングに適切な値 (ポイント単位) を指定します。

ポップオーバーの書式を設定するには、次の操作を行います。

ポップオーバーとポップオーバー内容領域を個別に書式設定できます。

1. レイアウトモードで、ポップオーバーを選択します。

ポップオーバーが非表示の場合、ポップオーバーボタンを選択して [書式] メニュー > [ポップオーバーを表示] を選択します。

2. インスペクタで外観 外観 タブをクリックします。

3. [ポップオーバー] または [ポップオーバー: 内容] をオブジェクトタイプの一覧 ([外観] タブの上部近く) で選択し、次の操作を行います。

 

目的

操作

ポップオーバーの枠またはポップオーバーの内容領域の枠の線のスタイルまたは色を変更する

[グラフィック] 領域の線のスタイルまたは色のオプションを選択します。

ポップオーバーの背景の外観またはポップオーバーの内容領域の背景を変更する

グラフィック領域で任意の塗りつぶしを選択します。

ヒント  ポップオーバーのカスタム枠は、ポップオーバーとその内容領域に異なる塗りつぶしを指定することで作成できます。

ポップオーバーに外側の影を追加する

[詳細なグラフィック] 領域で [外側の影] を選択します。

ポップオーバーの内容領域に内側の影を追加する

[詳細なグラフィック] 領域で [内側の影] を選択します。

ポップオーバーの枠とポップオーバーの内容領域の枠の間のパディングを変更する

[詳細なグラフィック] 領域の [パディング] に、値を指定します。

ポップオーバーのタイトルの外観を変更する

[ポップオーバーボタン設定] ダイアログボックスが開いていない場合は、ポップオーバーをダブルクリックするか、ポップオーバーを選択して [書式] メニュー > [ポップオーバーボタン設定] を選択します。

[テキスト] または [段落設定] 領域でオプションを選択します。

または書式設定バーでテキストオプションを使用します。書式設定バーが表示されていない場合は、レイアウトバーの書式設定 データ をクリックします。

関連項目 

テキストの書式設定