高度なツールの使用 > カスタムメニューの定義 > カスタムメニューセットの作成と編集
 

カスタムメニューセットの作成と編集

メモ  この機能は、[環境設定] ダイアログボックスの [一般] タブで [高度なツールを使用する] が選択されている場合に使用できます。高度なツールの使用を参照してください。

カスタムメニューセットを作成し、必要なメニューを含めることができます。この場合、ファイルと、個々のレイアウトにメニューを指定できます。

重要  カスタムメニューセットを複製すると、メニューセットのコピーが作成され、元のメニューセットと同じカスタムメニューが参照されます。カスタムメニューは複製されません。メニュー項目を変更すると、そのメニューが含まれているすべてのメニューセットのメニューが変更されます。

カスタムメニューセットを作成、編集、複製、または削除するには、次の操作を行います。

1. [ファイル] メニュー > [管理] > [カスタムメニュー...] > [カスタムメニュー] タブを選択します。

2. [カスタムメニューの管理] ダイアログボックスで設定を指定して、[OK] をクリックします。

[作成...] または [編集...] を選択した場合、[カスタムメニューセットの編集] ダイアログボックスが表示されます。

3. メニューセットに追加するメニューを指定します。

標準 FileMaker Pro Advanced メニューセットの複製と編集

1. [ファイル] メニュー > [管理] > [カスタムメニュー...] > [カスタムメニュー] タブをクリックします。

2. [作成...] をクリックします。

3. [カスタムメニューの作成] ダイアログボックスで、[FileMaker の標準メニューから作成する] をクリックし、一覧からメニューを選択してから [OK] をクリックします。

4. [カスタムメニューの編集] ダイアログボックスで [メニュー名] を変更し、他の設定を変更して [OK] をクリックします。

カスタムメニューの定義を参照してください。

5. 各標準 FileMaker Pro Advanced メニューで 2 から 4 の手順を繰り返します。

6. [カスタムメニューの管理] ダイアログボックスで、[カスタムメニューセット] タブをクリックし、[作成...] をクリックします。

7. [カスタムメニューセットの編集] ダイアログボックスで、[メニューセット名] に記述名 (たとえば [FileMaker Advanced の標準メニューのコピー] など) を入力し、[追加...] をクリックします。

8. [メニューの選択] ダイアログボックスで、このメニューセットのメニューを選択して [選択] をクリックします。

9. [カスタムメニューセットの編集] ダイアログボックスで、矢印 編集ボタン を上下にドラッグして一覧のメニュー項目の順序を変更し、[OK] をクリックします。

10. [カスタムメニューの管理] ダイアログボックスで、[OK] をクリックします。

メニューセットのインストールオプションの指定

メニューセットを作成したら、メニューセットのインストールオプションを指定する必要があります。次の操作ができます:

ファイルのデフォルトメニューセットを指定する

個々のレイアウトに対するメニューセットを指定する (レイアウトのメニューセットの指定を参照してください)

メニューセットを変更するスクリプトを作成する ([メニューセットのインストール] スクリプトステップを参照)

メニューセット内でメニューを指定し、モードに合わせて表示する (カスタムメニューの定義を参照)

メモ 

macOS:

カスタマイズしたメニューセットに [ヘルプ] メニューを含めない場合、オペレーティングシステムにより空の [ヘルプ] メニューがインストールされます。このメニューを取り除いたり、メニューバーのその他のオプションを変更したり、そのタイトルを変更することはできません。

FileMaker Pro Advanced メニューは、Apple メニューの後に追加されます。[終了] または [環境設定] メニュー項目はカスタマイズできません。[FileMaker Pro Advanced について] メニュー項目のみカスタマイズできます。

Windows: [終了] メニュー項目はカスタマイズできません。[終了] メニュー項目はカスタマイズできません。

追加するメニューを Shift - クリックまたは Ctrl + クリック (Windows) または command - クリック (macOS) し、複数のメニューをメニューセットに追加できます。

レイアウトを切り替えるたびに、FileMaker Pro Advanced は、[レイアウト設定] ダイアログボックスの [メニューセット] オプションに指定されているメニューセットをインストールします。

メニューセットをコピーしても、そのメニューセットで参照されているメニューはコピーされません。参照されているメニューは、貼り付け (ペースト) 先のファイルにすでに存在している必要があります。