作業を自動化するためのスクリプトの作成 > スクリプトの作成と編集
 

スクリプトの作成と編集

メモ  スクリプトステップ、そのオプション、および例については、スクリプトステップリファレンス (名前順) およびスクリプトステップリファレンス (種類順) を参照してください。スクリプトの例も参照してください。

スクリプトを作成または編集するには、次の操作を行います。

1. [スクリプト] メニュー > [スクリプトワークスペース...] を選択します。

または [ファイル] メニュー > [管理] > [スクリプト...] を選択します。

[スクリプトワークスペース] が開きます。スクリプトの作成と編集は、このウインドウの 3 つのパネル (左にあるスクリプトパネル、中央のスクリプト編集パネル、および右にあるスクリプトステップパネル) で行います。

2. スクリプトを作成するか、開きます:

スクリプトを作成するには、ヘルプボタン をクリックします。スクリプト編集パネルで、新しいスクリプトの名前を入力して Enter キー (Windows) または return キー (macOS) を押します。

スクリプトをプレビューするには、スクリプトパネルでスクリプト名をクリックします。[計算式] ボタン をクリックすると、プレビューからスクリプトの編集に切り替わります。

スクリプトを編集するには、スクリプトパネルでスクリプト名をダブルクリックします。スクリプトがスクリプト編集パネルですでに開いている場合は、スクリプトのタブをクリックしてアクティブにします。

3. スクリプトステップ名の入力を開始し、表示される一覧からスクリプトステップを選択します。

またはスクリプトステップパネルでスクリプトステップをダブルクリックします。

4. スクリプトステップにオプションがある場合は角カッコ ([ ]) に囲まれたテキストまたはスクリプトステップの横にある アクションメニューボタン で表示されるので、次のいずれかの操作を行います:

角カッコ内のテキストをクリックして、表示されるオプションを指定します。

アクションメニューボタン をクリックして、表示されるオプションを指定します。

角カッコの間をクリックして計算式を編集するか、[カテゴリ別のソート] ボタン をクリックして [計算式の指定] ダイアログボックスを開きます。インラインで編集できるのは一部の計算式だけです。

メモ  スクリプトステップを編集するとき、[記憶する] オプションが表示されることがあります。記憶はスクリプトステップを最後に編集したときに指定した条件が、スクリプトステップを実行するときに使用されることを示します。

5. スクリプト編集パネルで作業するとき、次のいずれかの操作を行います:

 

目的

操作

スクリプトに 1 行追加する

次のいずれかの操作を行います:

Enter または return を押します。

スクリプトの最後の行が空白でない場合、最後の行を選択して、下向矢印キーを押します。

選択した行の上に 1 行追加する

Shift+Enter (Windows) または shift-return (macOS) を押します。

スクリプト内の行を移動する

上向矢印キーまたは下向矢印キーを押します。

スクリプトにコメントを追加する

空白行で「#」と入力するか、スクリプトステップパネルから [コメント] を選択します。スクリプトで [# (コメント)] スクリプトステップを使用すると、他のユーザがこのスクリプトを参照または変更するときに便利です。

[お気に入り] カテゴリにスクリプトステップを追加する

スクリプトステップパネルでスクリプトステップを選択して [スクリプトの管理] メニューボタン をクリックします。[お気に入り] カテゴリからスクリプトステップを取り除くには、スクリプトステップを選択して [グレーの星] ボタン をクリックします。

メモ  スクリプトステップパネルがアルファベット順にソートされている場合、スクリプトステップを [お気に入り] カテゴリに追加することはできません。

スクリプトステップに関する情報を表示する

スクリプトステップパネルでスクリプトステップをクリックします。説明が一覧の下に表示されます。詳細を表示するには、[互換性] ボタン をクリックします。

スクリプトステップをアルファベット順またはカテゴリ別に表示する

スクリプトステップパネルで [スクリプトの実行] ボタン をクリックしてスクリプトステップをアルファベット順に表示するか、[スクリプトの管理] メニューボタン をクリックしてカテゴリ別に表示します。

スクリプトステップをサポートする FileMaker 製品を確認する

[新規フォルダ] ボタン をクリックして、製品を選択します。選択した製品と互換性のあるすべてのスクリプトステップが表示されます。

スクリプトステップをコピーして貼り付け (ペースト) する

スクリプトのコピーと貼り付け (ペースト) を参照してください。

スクリプトステップを複製する

スクリプトステップを選択して [編集] メニュー > [複製] (Windows) または [ステップを複製] (macOS) を選択します。

スクリプトステップを削除する

スクリプトステップを選択して Delete キーを押します。

スクリプト内のスクリプトステップの順番を変更する

スクリプト編集パネル内のスクリプトステップをスクリプト内の新しい位置にドラッグします。

複数のスクリプトステップを選択する

Ctrl キー (Windows) または command キー (macOS) を押しながらクリックします。複数のステップを追加、複製、または削除することができます。

スクリプトステップオプションに含まれるスクリプトを開く

Ctrl キー (Windows) または command キー (macOS) を押しながらスクリプトステップオプションをクリックします。

スクリプトを実行する

[互換性] ボタン をクリックします。

メモ  スクリプト名の横に表示されるアスタリスク (*) は、スクリプトが変更されていて保存されていないことを示します。

6. タブを閉じて [保存] をクリックします。

または [スクリプトワークスペース] で [ファイル] メニュー > [スクリプトの保存] を選択 (Windows)、または FileMaker Pro Advanced メニューバーの [スクリプト] メニュー > [スクリプトの保存] を選択 (macOS) します。

スクリプトを管理するには、次の操作を行います。

 

目的

操作

スクリプトの名前変更、複製、または削除する

スクリプト名を右クリックしてメニューから選択します。スクリプト編集パネルでスクリプト名を 2 回クリックしてスクリプトの名前を変更することもできます。

スクリプトの順序を変更する

一覧の目的の位置にスクリプト名をドラッグします。

スクリプトの印刷

Windows: [スクリプトワークスペース] の [ファイル] メニュー > [スクリプトの印刷...] を選択します。

macOS: FileMaker Pro Advanced メニューバーの [ファイル] メニュー > [印刷...] を選択します。

スクリプトを完全アクセス権で実行する

スクリプトを右クリックして、[完全アクセス権を付与] を選択します。以下の「完全アクセス権でのスクリプトの実行」を参照してください。

スクリプトパネル内のフォルダを管理する

フォルダを使用したスクリプトの管理を参照してください。

完全アクセス権でのスクリプトの実行

スクリプトを完全アクセス権で実行するように設定すると、アクセス権が制限されたユーザは、通常は実行できないタスク (レコードのエクスポートや削除など) をスクリプトによって実行できるようになります。

アクセス権は変更されませんが、スクリプトにはユーザよりも多くのアクセス権が付与されます。またスクリプトでこの機能が有効になっている場合を除き、完全アクセス権は後に続くサブスクリプトに継承されません。

スクリプトを完全アクセス権で実行するように設定できるのは、完全アクセスのアクセス権セットを持つユーザだけです。この機能が有効になっているスクリプトの編集や削除ができるのは、完全アクセス権を持つユーザだけです。

スクリプトが完全アクセス権で実行できるのは、スクリプトが定義されているファイル内だけです。スクリプトでは外部ファイルのアクセス制限を変更できません。たとえば、完全アクセス権で実行するように設定されているスクリプトは、アクセスが制限された外部ファイルのレコードを削除できません。

完全アクセス権のないユーザに対し、そのユーザに割り当てられたアクセス権セットで [変更可能] が設定されているスクリプトを編集する権限を許可することができますが、スクリプトを作成、複製、インポート、削除するには、完全アクセス権が必要です。

メモ 

スクリプトを作成しながら問題がないか確認するには、スクリプト編集パネルのタブを右クリックして [問題をチェック] を選択します。スクリプトがチェックされ、オプションがないなど問題のある行が強調表示されます(すべての問題を検出できるわけではありません)。[スクリプトワークスペース設定] にある [構文の色] タブの [問題] のデフォルトの色で行が強調表示されます。

スクリプトステップおよび問題などの条件の色の設定を編集するには、スクリプトワークスペースで、[表示] メニュー > [環境設定...] (Windows) または [表示] メニュー > [スクリプトワークスペース設定...] (macOS) を選択して [構文の色] タブをクリックします。

スクリプトを新しいウインドウで編集するには、スクリプト編集パネルでタブを右クリックして [タブを新規ウインドウに移動] を選択するか、Alt キー (Windows) または option キー (macOS) を押しながらスクリプトパネル内のスクリプトをダブルクリックします。スクリプトが [スクリプトを編集] ダイアログで開きます。

スクリプトを完全アクセス権で実行できるようにするには、[ファイル] メニュー > [完全アクセス権を付与] (Windows) または [スクリプト] メニュー > [完全アクセス権を付与] (macOS) を選択します。

ボタン処理をスクリプトに変換することによって [スクリプトを編集] ダイアログボックスにアクセスした場合、Ctrl+R (Windows) または command-R (macOS) を押してスクリプトの名前を変更できます。

関連項目 

計算式での演算子の使い方

スクリプトステップリファレンス (種類順)

スクリプトステップリファレンス (名前順)

レイアウト上のボタンおよびボタンバーの操作

[スクリプト] メニューの操作

スクリプトアクセス権の編集

Web 上でのデータベースの公開

スクリプトのデバッグ

スクリプトステップの無効化