データの追加と表示 > スペルチェック
 

スペルチェック

FileMaker Pro Advanced では、次の場所にあるテキストのスペルをチェックできます:

フィールドで選択した単語または文章

現在のレコードでのみ表示されているフィールド (関連フィールドがある場合はその関連フィールドも含む)

現在の対象レコードの全レコードのみ表示されているフィールド (関連フィールドがある場合はその関連フィールドも含む)

レイアウトモードで現在のレイアウトにあるすべてのテキストオブジェクト (前面にないタブパネルまたはスライドパネルのテキストオブジェクトを含む)

また FileMaker Pro Advanced では、入力時にスペルをチェックするように設定することもできますし、編集中のテキスト内のスペルのミスの可能性のある部分に赤い点線の下線を付けて示すこともできます。スペルチェックオプションは、[ファイルオプション] ダイアログボックスの [英文スペルチェック] タブで設定できます。ファイルオプションの設定を参照してください。

FileMaker Pro Advanced ではデフォルトでフィールドごとにスペルがチェックされます。個々のフィールドのスペルチェックを無効にするには、インスペクタのデータ 「へいせい」という日本語の漢字 タブの [動作] 領域で、[視覚的なスペルチェックを適用しない] を選択します。

スペルチェックが実行される際には、メイン辞書とユーザ辞書が使用されます。メイン辞書として英文のスペルチェック用辞書 (usenglsh.mpr) が使用されるようにあらかじめ設定されています。メイン辞書を編集することはできませんが、別の言語に変更することはできます。メイン辞書は常に使用できます。

FileMaker Pro Advanced には、オランダ語、フランス語、イタリア語、ドイツ語、ドイツ語 (スイス)、ポルトガル語 (ブラジル)、ポルトガル語 (ポルトガル)、スペイン語、スウェーデン語、英語 (英国)、英語 (米国)、英語 (米国 (医学用語)) のスペルチェック用辞書が含まれています。

ユーザ辞書 (user.upr) は、編集可能な辞書として補助的に使用します。複数のユーザ辞書を作成できますが、同時に使用できるのは 1 つのみです。ユーザ辞書はいつでも切り替えることができます。また、ユーザ辞書を完全にオフにして、メイン辞書のみを使用することもできます。

現在のフィールド、レコード、対象レコード、またはレイアウトで、スペルチェックを実行するには、次の操作を行います。

1. レコードまたはレイアウトを表示するか、検索により抽出された対象レコードを表示するか、またはチェックするテキストを選択します。

2. [編集] メニュー > [英文スペルチェック] からコマンドを選択します。

3. [単語: ] ボックスに疑わしい単語が表示された場合は、オプションを選択します。

メモ  書き込みが禁止された、またはパスワードで保護されたファイルやフィールド内の単語を変更することはできません。そういった単語が表示された場合は、[無視] をクリックします。

 

目的

操作

スペルの間違った単語を辞書内の単語に置き換える

修正候補の一覧から単語を選択して、[置換] をクリックします。

スペルチェック用辞書にない単語のスペルミスを修正する

[単語: ] ボックスに、置き換える単語を直接入力します。[チェック] をクリックして、入力した単語のスペルを確認するか、または [置換] をクリックします。

単語を修正しないでそのままにする

[すべて無視] をクリックします。その単語は、スペルチェックを終了するまで検出されなくなります。

スペルを修正しないで、単語をユーザ辞書に追加する

[追加] をクリックします。

メモ  ユーザ辞書を編集するには、編集するユーザ辞書を選択する必要があります (下記を参照してください)。

4. スペルチェックが終了したら、[終了] をクリックします。

メモ  Web ビューア集計フィールドオブジェクトフィールドでは、スペルチェックができません

スペルチェック用辞書を操作するには、次の操作を行います。

スペルチェック用辞書の作成、選択、編集を行うには、[編集] メニュー > [英文スペルチェック] > [辞書指定...] を選択し、オプションを選択して [OK] をクリックします。

ユーザ辞書の編集、エクスポート、インポートを行うには、[編集] メニュー > [英文スペルチェック] > [ユーザ辞書...] を選択し、オプションを選択して [OK] をクリックします。