レイアウトとレポートの作成と管理 > レイアウト上のポップオーバーの操作 > ポップオーバーの追加
 

ポップオーバーの追加

ポップオーバーレイアウトに追加して、オブジェクトを整理してデータ入力を簡単にすることができます。ポップオーバーをレイアウトに追加するには、ポップオーバーボタンを作成します。FileMaker Pro Advanced では同時にポップオーバーも作成されます。ポップオーバーにフィールドおよびその他のレイアウトオブジェクトを追加します。

ポップオーバーをレイアウトに追加するには、次の操作を行います。

1. レイアウトモードに切り替えて、レイアウトポップアップメニューからフィールドを追加するレイアウトを選択します。

2. ステータスツールバーで、次の操作を行います:

Windows: ボタンツール 前のパネルに移動するボタン またはポップオーバーボタンツール 次のパネルに移動するボタン の横の矢印をクリックしてメニューから [ポップオーバーボタン] を選択します。その後、十字線をドラッグしてポップオーバーボタンを描画します。

macOS: ボタンツール 前のパネルに移動するボタン またはポップオーバーボタンツール 次のパネルに移動するボタン を押したまま、メニューから [ポップオーバーボタン] を選択します。その後、十字線をドラッグしてポップオーバーボタンを描画します。

ポップオーバーとともにポップオーバーボタンがレイアウトに表示されます。

3. [ポップオーバーボタンの設定] ダイアログボックスで、ラベルを表示する方法を選択します。

デフォルトでは、テキストのラベルだけが作成され、中央揃えで配置されます。ボタンの定義または変更を参照してください。

4. ポップオーバーの追加オプション (ポップオーバーを開く方向、ポップオーバーのタイトルの変更、タイトルバーの表示など) を選択します。

ポップオーバー設定の変更を参照してください。

5. 1 つまたは複数のスクリプトトリガをポップオーバーに割り当てるには、[スクリプトトリガ設定...] をクリックして 1 つまたは複数のスクリプトトリガを選択します。

スクリプトトリガの設定および作業を自動化するためのスクリプトの作成を参照してください。

6. オブジェクトをポップオーバーに追加するには、ポップオーバーを選択します。ポップオーバーが表示されない場合は、[書式] メニュー > [ポップオーバーを表示] を選択します。オブジェクトを追加するには、ステータスツールバーのレイアウトツールを使用するか、[挿入] メニューから項目を選択するか、オブジェクトをポップオーバーにドラッグします。

7. ポップオーバーの閉じるボタンをクリックして、ポップオーバーを閉じます。

メモ 

ポップオーバーはポータルの内側に配置できますが、ポータルに含まれるポップオーバー上にポータルを配置することはできません。

Windows: ポップオーバーは、ブラウズモードで Web ビューアまたはインタラクティブオブジェクトの前に表示できません。これらのオブジェクトが重なって表示されないようにするために、ポップオーバーが小さくなるか (可能な場合)、これらのオブジェクトの背後に表示されます。

ポップオーバー上のフィールドのデータはエクスポートできますが、次の例外があります:

データを Excel として保存または送信する場合 ([ファイル] メニュー > [レコードの保存/送信] > [Excel...] を使用)、ポップオーバー上のフィールドは Excel ファイルに含まれません。この場合は、[ファイル] メニュー > [レコードのエクスポート...] を選択してください。出力先のファイルに名前を付けて Excel のオプションを設定した後、[フィールドデータのエクスポート順] ダイアログボックスの [現在のテーブル] を選択して、エクスポートするフィールドを選択します。FileMaker Pro Advanced からのデータのエクスポートを参照してください。

表形式でコンテキストメニューを使用してレコードをコピー、またはレコードを PDF として保存/送信する場合、ポップオーバー上のフィールドは PDF ファイルに含まれません。

[レコード/検索条件コピー] スクリプトステップまたは [全レコード/検索条件コピー] スクリプトステップを使用すると、ポップオーバー上のフィールドは出力先のファイルに含まれません。

ポップオーバー内のフィールドをスクリプトステップが指定している場合、ポップオーバーが開いて、フィールドが選択されます。ただし、同じフィールドがレイアウト上の他の場所に表示されていてスクリプトがそのフィールドを最初に検出する場合は、同じフィールドを含むポップオーバーは前面に表示されません。代わりに、オブジェクト名をフィールドに割り当て、[オブジェクトへ移動] スクリプトステップを使用してフィールドのそのインスタンスに移動します。

レイアウトモードでは、ポップオーバーボタンにバッジ フィールド/コントロールツール が表示されます。バッジが表示されない場合は、[表示] メニュー > [オブジェクト] > [ポップオーバーボタン] を選択してください。

関連項目 

ボタン、ポップオーバーボタン、およびポップオーバーの書式設定

レイアウトオブジェクトの自動サイズ変更オプションの設定