Creazione e gestione di formati e resoconti > Utilizzo dei campi in un formato > Posizionamento e rimozione dei campi da un formato
 

Posizionamento e rimozione dei campi da un formato

Dopo aver definito un campo, è possibile aggiungerlo ovunque in un formato. I campi possono essere della stessa tabella o di una tabella correlata.

È possibile posizionare i campi correlati direttamente sul formato o in un portale, ma i risultati sono differenti. Vedere Scelta della posizione dei campi correlati.

Per posizionare e rimuovere i campi in un formato:

Nel modo Formato scheda, selezionare il formato su cui lavorare dal menu a tendina Formato. Quindi:

 

Per

Eseguire questa operazione

Posizionare un campo utilizzando la scheda Campi

Nella scheda Campi, trascinare un campo dall'elenco alla posizione desiderata sul formato.

Se si sta posizionando un campo in un portale, posizionarlo nella prima riga del portale.

Per i campi correlati, assicurarsi che ogni campo nel portale sia di una tabella correlata alla tabella dalla quale è previsto che il portale visualizzi i record. (Vedere Creazione di portali per visualizzare i record correlati).

Per selezionare un campo in una tabella diversa, selezionare la tabella dall'elenco sopra l'elenco dei campi. (Se l'elenco delle tabelle non è visibile, fare clic su Strumento Pulsante popover).

Oppure selezionare Gestisci database dall'elenco delle tabelle e creare una relazione o una tabella, quindi selezionare un campo correlato dall'elenco dei campi.

Il nome del campo viene visualizzato nel campo, a meno che non si sia scelto di visualizzare dati di esempio (menu Visualizza > Mostra > Dati di esempio). I campi delle tabelle correlate vengono visualizzati come ::Nome campo.

Tutti i campi ad eccezione dei campi Contenitore visualizzano linee base del testo, per indicare il punto di visualizzazione dei dati nel modo Usa e per ottimizzare l'allineamento dei campi.

Vedere Definizione e modifica dei campi nella scheda Campi.

Posizionare un campo utilizzando lo strumento Campo

Trascinare un campo dallo strumento Campo Badge popover sulla barra degli strumenti alla posizione desiderata sul formato, quindi selezionare il nome di un campo nella finestra di dialogo Specifica il campo. Per includere un'etichetta del campo, selezionare Crea etichetta.

Aggiungere e ridimensionare un campo

Fare clic sulla freccia accanto allo strumento Campo/Controllo Pulsante icona a sinistra, testo a destra (Windows) o fare clic e tenere premuto lo strumento Campo/Controllo Pulsante icona a sinistra, testo a destra (macOS) nella barra degli strumenti. Trascinare il puntatore a croce per disegnare il campo, quindi selezionare il nome di un campo nella finestra di dialogo Specifica il campo.

Aggiungere un campo con uno stile di controllo specifico

Fare clic sulla freccia accanto allo strumento Campo/Controllo Pulsante icona a sinistra, testo a destra (Windows) o fare clic e tenere premuto lo strumento Campo/Controllo Pulsante icona a sinistra, testo a destra (macOS) nella barra degli strumenti, quindi selezionare un campo o uno stile di controllo. Trascinare il puntatore a croce per disegnare il campo, quindi selezionare il nome di un campo nella finestra di dialogo Specifica il campo.

Sostituire un campo con un altro campo

Fare doppio clic sul campo nel formato, quindi selezionare il nome di un campo nella finestra di dialogo Specifica il campo.

Rimuovere un campo da un formato

Fare clic sul campo nel formato, quindi premere Backspace o Canc. La rimozione di un campo in questo modo non comporta l'eliminazione del campo o dei relativi dati dal database. Vedere Definizione e modifica dei campi.

Note 

Quando si aggiunge un campo a un formato, la sua formattazione è ricavata dal tema applicato al formato. È possibile applicare uno stile personalizzato per cambiare gli attributi di visualizzazione del campo. Vedere Modifica di oggetti, sezioni e sfondo del formato.

Per determinare una dimensione appropriata per un campo, visualizzare i dati di esempio nel campo dal record corrente anziché il nome del campo. Selezionare il menu Visualizza > Mostra > Dati di esempio.

Per inserire i dati dei campi in una riga o in un blocco di testo, utilizzare i campi di fusione. Vedere Posizionamento dei campi di fusione in un formato.

Per inserire un'immagine statica (come un logo o un elemento decorativo) in un formato in modo che venga visualizzata in ciascun record, creare, incollare o importare l'immagine direttamente nel formato, quindi posizionarla nella sezione Corpo. Vedere Disegnare e inserire oggetti nel formato.

Se il nome di un campo non viene visualizzato entro i bordi del campo nel modo Formato scheda, fare doppio clic sul campo per selezionarne il nome nella finestra di dialogo Specifica il campo.

È possibile posizionare campi nell'area grigia sul lato destro del formato. Questo permette di salvare campi nel formato o utilizzarli nelle istruzioni di script, impedendo loro però di apparire nei modi Usa, Trova e Anteprima. Gli utenti non possono selezionare, utilizzare o stampare tali campi.

Argomenti correlati 

Copia, duplicazione ed eliminazione degli oggetti

Definizione delle liste valori

Impostazione di un campo per il completamento automatico durante l'inserimento dei dati

Impostazione di un campo per visualizzare un calendario a discesa

Impostazione di un campo per visualizzare un menu a comparsa, un gruppo di caselle di controllo o un altro comando