Creazione di un'app personalizzata > Impostazione delle opzioni file
 

Impostazione delle opzioni file

È possibile impostare preferenze per le informazioni di accesso predefinite del file corrente, per il formato, per l'icona rappresentativa, per il controllo ortografico, per la gestione del testo e per gli script di apertura e chiusura del file. Per impostare le preferenze per tutti i file, vedere Impostazione delle preferenze.

Nota  Per modificare gli elementi in qualsiasi scheda, tranne la scheda Ortografia, è necessario accedere con un set di privilegi Accesso completo.

Per impostare opzioni per aprire e chiudere il file corrente:

1. Selezionare il menu File > Opzioni file e fare clic sulla scheda Apri se non è già selezionata.

 

Seleziona

Per

Versione minima consentita per aprire questo file, quindi scegliere una versione dall'elenco

Impedire di aprire un file con versioni client o host FileMaker precedenti alla versione specificata.

Il file deve essere in locale e non condiviso quando viene impostata l'opzione. Tuttavia, una volta che l'opzione è impostata, il file può essere ospitato in remoto. Tutti i file vengono visualizzati nella finestra di dialogo Host, ma è possibile aprire solo i file qualificati. Per potere impostare questa opzione è necessario l'accesso esclusivo al file, pertanto assicurarsi che nessun un altro stia utilizzando il file.

Accedi usando, quindi Nome utente e password e inserire un nome utente e una password

Questa è la selezione predefinita. L'impostazione predefinita è Accedi usando selezionata con l'opzione Nome utente e password impostata su Admin e con password vuota.

Accedere automaticamente usando un account (nome utente) specifico e una password all'apertura del database. Se il nome utente predefinito è valido, ma la password non lo è, verrà richiesto di inserire un'altra password.

Per ignorare provvisoriamente la password predefinita e inserirne un'altra, premere Maiusc (Windows) o Opzione (macOS) durante l'apertura del file.

Nota  Sono supportati solo gli account File FileMaker o Server esterno (vedere Creazione e modifica dell'accesso tramite account). Se il file esegue l'autenticazione tramite un provider di identità OAuth, l'opzione Accedi usando viene ignorata.

Accedi usando , quindi Account ospite

Accedere automaticamente utilizzando un account Ospite.

Consenti a Gestione credenziali di salvare la password (Windows) o Consenti ad Accesso Portachiavi di salvare la password (macOS)

Consentire di salvare la password per il file corrente in Gestione credenziali (Windows) o nel portachiavi (macOS e iOS).

Se questa opzione non è selezionata, gli utenti non saranno in grado di salvare la password.

Richiedi codice iOS

Richiedere agli utenti di eseguire l'autenticazione con iOS prima che FileMaker Go possa accedere al portachiavi.

Passa al formato, quindi scegliere un formato dall'elenco nella finestra di dialogo Specifica formato

Visualizzare il formato indicato all'apertura del file. Se non si seleziona questa opzione, verrà aperto il formato visualizzato al momento in cui si lavorava sul file oppure quello specificato nello script di avvio. (Vedere le opzioni dei trigger di script di seguito).

Se è stato selezionato un formato, il suo nome appare a destra del pulsante Specifica di questa opzione. Per cambiare il formato da utilizzare, fare clic su Specifica, quindi scegliere un formato dall'elenco.

Nota FileMaker Pro Advanced salva il formato corrente solo se il file è stato modificato in modo significativo, ad esempio se sono stati modificati un record o lo schema del database.

Nascondi tutte le barre degli strumenti

Nascondere tutte le barre degli strumenti quando si apre il file. Le barre degli strumenti vengono nascoste come se si eseguissero l'istruzione di script Mostra/Nascondi barre degli strumenti e l'istruzione di script Mostra/Nascondi barra dei menu.

2. Fare clic su OK per salvare le modifiche o fare clic su un'altra scheda per impostare altre opzioni per il file.

Per selezionare un'icona per il file corrente:

1. Selezionare il menu File > Opzioni file e fare clic sulla scheda Icona.

2. Selezionare o creare un'icona per rappresentare il file corrente nelle finestre Preferiti e Recenti di FileMaker Pro Advanced e nel Centro di comando di FileMaker Go e FileMaker WebDirect.

 

Per

Eseguire questa operazione

Visualizzare l'icona predefinita del file FileMaker Pro Advanced o un'altra icona predefinita

Scegliere un'icona dall'elenco.

Specificare un'immagine personalizzata

Fare clic su Personalizzato, quindi selezionare un file di immagine e fare clic su Apri (Windows) o su Inserisci (macOS).

I formati supportati sono PNG e JPEG. FileMaker Pro Advanced ridimensiona l'immagine secondo le necessità. Per ottenere risultati migliori su display ad alta risoluzione, selezionare un'immagine da 288 x 288 pixel.

Nota  L'icona selezionata non viene visualizzata sul desktop.

Adattare un'immagine personalizzata in modo proporzionale rispetto alla sua dimensione maggiore

Selezionare Adatta in modo che la larghezza e l'altezza dell'immagine si adattino all'interno dell'area.

Adattare un'immagine personalizzata in modo proporzionale rispetto alla sua dimensione minore

Selezionare Adatta per riempire in modo che la larghezza e l'altezza dell'immagine riempiano interamente l'area.

La scheda Icona mostra come l'icona selezionata verrà visualizzata con dimensioni diverse.

3. Fare clic su OK per salvare le modifiche o fare clic su un'altra scheda per impostare altre opzioni per il file.

Nota  Se si apre un file di database crittografato, potrebbe essere visualizzata l'icona predefinita di FileMaker Pro Advanced, a meno che il file non sia stato aperto in precedenza.

Per impostare le opzioni di controllo ortografico per il file corrente:

1. Selezionare il menu File > Opzioni file e fare clic sulla scheda Ortografia.

 

Seleziona

Per

Indica le parole sospette con una sottolineatura speciale

Marcare le possibili parole non corrette con una sottolineatura di punti rossi (nel modo Usa, Trova e Formato scheda).

Nota  Se un file è condiviso, i client possono modificare questa opzione in modo indipendente, ma l'impostazione rimane configurata solo finché il client non chiude il file. Per modificare questa opzione per tutti i client, l'host deve chiudere il file condiviso, aprire il file localmente con FileMaker Pro Advanced, modificare l'impostazione e condividere nuovamente il file.

Disattivata

Non ricevere nessun segnale quando è stata digitata una parola sospetta.

Segnale acustico

Ricevere un segnale audio quando è stata digitata una parola sospetta.

2. Fare clic su OK per salvare le modifiche o fare clic su un'altra scheda per impostare altre opzioni per il file.

Il controllo ortografico durante la digitazione può essere più lento rispetto alle altre opzioni per il controllo ortografico se, nel campo attivo, è visibile una grande quantità di testo. Vedere Controllo ortografico.

Per impostare le opzioni di gestione del testo e di immissione dei dati per il file corrente:

Nota  È necessario accedere con privilegi di accesso completi per modificare le opzioni della scheda Testo.

1. Selezionare il menu File > Opzioni file e fare clic sulla scheda Testo.

2. Nell'area Gestione testo, selezionare una o più delle seguenti opzioni:

 

Seleziona

Per

Usa le virgolette curve

Usare le virgolette curve singole o doppie. Se si deseleziona questa opzione o si utilizza un font che non dispone di virgolette curve, verranno utilizzate le virgolette e gli apostrofi semplici. Le modifiche hanno effetto solo sulle nuove digitazioni e non sui dati esistenti

Usa interruzione di riga delle lingue Asiatiche

Controllare l'interruzione di riga delle lingue Asiatiche. Questa opzione è attivata per default. Se questa opzione è disattivata, la regole standard delle lingue Asiatiche che determinano i caratteri con cui una riga di testo può iniziare e finire vengono ignorate.

Usa interruzione di riga delle lingue latine

Controllare l'interruzione di riga delle lingue latine, compresa la funzionalità di ritorno a capo automatico. Questa opzione è attivata per default. Se questa opzione è disattivata, le lettere e gli spazi vengono trattati allo stesso modo dei simboli e le parole delle lingue latine non vengono considerate come unità. Una parola viene mandata a capo quando supera la larghezza del campo o del blocco di testo, che può verificarsi a metà parola.

Sovrascrivi il valore inserito quando l'IME asiatico è attivo su (Windows)

Sovrascrivere i caratteri esistenti nella posizione del cursore con i nuovi caratteri inseriti dall'utente quando è attivo un editor per il metodo di immissione asiatico (IME). L'impostazione predefinita prevede che questa opzione sia disattivata.

3. Nell'area immissione di dati, selezionare una o più delle seguenti opzioni:

 

Seleziona

Per

Usa sempre le impostazioni di sistema correnti

Utilizzare le impostazioni correnti del sistema per l'immissione di numeri, date e ore. Questa opzione è predefinita.

Usa sempre le impostazioni salvate del file

Utilizzare le impostazioni di sistema salvate con il file per la visualizzazione e l'immissione di numeri, date e ore.

Chiedi conferma se le impostazioni sono diverse

Richiedere all'utente di scegliere le impostazioni di sistema da utilizzare per inserire i dati in un campo Numero, Data, Ora o Indicatore data e ora creato usando impostazioni di sistema diverse da quelle correnti.

4. Fare clic su OK per salvare le modifiche o fare clic su un'altra scheda per impostare altre opzioni per il file.

Per aggiungere, modificare o eliminare un trigger di script per un file:

1. Selezionare il menu File > Opzioni file e fare clic sulla scheda Script Trigger.

2. Selezionare uno o più trigger di script nell'elenco.

 

Seleziona

Per

SuAperturaPrimaFinestra

Eseguire uno script ogni volta che si apre una finestra di un file di database quando non è aperta nessun'altra finestra del file. Vedere trigger di script SuAperturaPrimaFinestra.

SuChiusuraUltimaFinestra

Eseguire uno script ogni volta che si chiude la finestra aperta per ultima di un file di database. Vedere trigger di script SuChiusuraUltimaFinestra.

SuAperturaFinestra

Eseguire uno script ogni volta che si apre una finestra di un file di database. Vedere trigger di script SuAperturaFinestra.

SuChiusuraFinestra

Eseguire uno script ogni volta che si chiude una finestra di un file di database. Vedere trigger di script SuChiusuraFinestra.

SuCambioFileAVPlayer

Eseguire uno script se si sta riproducendo un file multimediale da un campo o da un URL e l'impostazione di un utente o di un'istruzione di script cambia lo stato della riproduzione. Vedere trigger di script SuCambioFileAVPlayer.

3. Fare clic su OK per salvare le modifiche o fare clic su un'altra scheda per impostare altre opzioni per il file.

Argomenti correlati 

Definizione dell'immissione automatica dei dati

Definizione della verifica dei campi

Apertura di file protetti da password

Automatizzazione delle attività con gli script

Impostazione dei trigger di script

Azioni che non attivano i trigger di script