Creazione dei grafici dai dati > Esempio: Rappresentazione grafica dei dati delimitati
 

Esempio: Rappresentazione grafica dei dati delimitati

FileMaker Pro Advanced può rappresentare graficamente più inserimenti di dati da un singolo campo se ogni valore nel campo è separato da un carattere di ritorno a capo (dati separati da ritorni a capo).

Informazioni sul grafico

In questo esempio verrà creato un nuovo file contenente due campi separati da ritorni a capo: Paese e Numero clienti. I campi vengono collocati su un unico formato e tutti i dati vengono memorizzati su un solo record. A questo punto si crea un istogramma che confronti il numero di clienti situati in ogni Paese.

Creare un file

1. Selezionare il menu File > Crea nuovo, quindi fare doppio clic su Vuoto.

2. Assegnare al file il nome Clienti a livello mondiale, quindi fare clic su Salva per salvare il file sull'hard disk.

Il file si apre nel modo Usa. Se viene visualizzata la finestra di dialogo Gestisci database, fare clic su OK. Vengono creati la prima tabella e il primo formato. Entrambi hanno lo stesso nome del file.

Definire e formattare i campi

1. Selezionare il menu Visualizza > Modo Formato scheda.

2. Nella scheda Campi, fare clic su Icone Istogramma in pila e Barre in pila per aggiungere un nuovo campo, quindi digitare Paese.

3. Creare un altro campo Numero clienti.

4. Sul formato, selezionare il campo Numero clienti e la relativa etichetta e trascinarli verso il basso di pochi millimetri.

5. Selezionare il campo Paese e trascinare il quadratino inferiore verso il basso finché nel campo non vengono visualizzate cinque righe.

6. Selezionare il campo Numero clienti e trascinare il quadratino inferiore verso il basso finché nel campo non vengono visualizzate cinque righe.

7. Selezionare il menu Formati > Salva formato, quindi fare clic su Esci dal formato per salvare le modifiche e tornare al modo Usa.

Suggerimento  È possibile selezionare Salva automaticamente modifiche al formato (senza conferma) per salvare le modifiche al formato quando si esce.

Aggiungere dati al file

1. Fare clic su Nuovo record nella barra strumenti di stato.

2. Nel campo Paese, digitare quanto segue, premendo Invio o Ritorno dopo il nome di ogni Paese.

Spagna
Italia
Giappone
Germania
Stati Uniti

3. Nel campo Numero clienti, digitare quanto segue, premendo Invio o Ritorno dopo ogni valore.

15
6
23
10
29

Sono stati creati due campi contenenti dati separati da ritorni a capo.

Creazione di un istogramma per confrontare il numero di clienti di ogni Paese

1. Fare clic su Modifica formato nella barra formato per passare al modo Formato scheda.

2. Trascinare il bordo grigio della sezione Corpo verso il basso per fare spazio al grafico.

3. Fare clic sullo strumento Grafico pulsante Specifica nella barra degli strumenti, quindi fare clic nella sezione del formato Corpo e trascinare un ampio rettangolo nel punto in cui si desidera visualizzare il grafico.

Si apre la finestra di dialogo Impostazione grafico.

4. In Impostazione grafico, fare clic su Origine dati e selezionare Record corrente (dati delimitati).

5. Nell'area Grafico di Impostazione grafico, digitare quanto segue:

 

Per

Eseguire questa operazione

Titolo

Digitare Clienti per Paese.

Tipo

Scegliere Istogramma.

Asse X (orizzontale)

In Titolo, digitare Paesi.

In Dati, fare clic su Pulsante Nuovo campo, selezionare Specifica Nome campo, Paese nella lista, quindi fare clic su OK.

I valori dei dati del campo Paese appaiono sotto il grafico. Sono le etichette per le colonne del grafico (serie X). Questi sono i dati confrontati.

Asse Y (verticale)

In Titolo, digitare Numero di clienti.

In Dati, fare clic su Pulsante Nuovo campo, selezionare Specifica Nome campo, Numero clienti nella lista, quindi fare clic su OK.

Le colonne del grafico mostrano i valori dei dati del campo Numero clienti (serie Y). Questi sono i dati misurati.

6. Fare clic su OK.

7. Selezionare il menu Formati > Salva formato, quindi fare clic su Esci dal formato per salvare le modifiche e tornare al modo Usa.

Ogni valore separato da ritorno a capo nel campo Paese corrisponde ad un valore separato da ritorno a capo nel campo Numero soci nell'ordine in cui sono stati inseriti i dati.