Accesso a origini dati esterne > Utilizzo di origini dati esterne > Modifica di origini dati ODBC
 

Modifica di origini dati ODBC

Un'origine dati ODBC consente ad un file FileMaker di accedere ai dati dalle tabelle ODBC esterne. È possibile visualizzare e aggiornare le tabelle ODBC in modo interattivo nel grafico delle relazioni in modo simile a come si visualizzano e si aggiornano le tabelle FileMaker.

FileMaker può collegarsi a molti sistemi di gestione di database relazionali (RDBMS) che forniscono API ODBC per l'uso esterno. Vedere Configurazione di un driver client ODBC per una lista delle origini dati supportate.

Importante  Per utilizzare le origini dati ODBC è necessario:

Collegarsi all'origine dati attraverso un driver ODBC e configurare i DSN. Vedere Configurazione di un driver client ODBC.

Aggiungere un'origine dati ODBC. Vedere Collegamento a origini dati esterne.

Dopo aver collegato l'origine dati ODBC a un file FileMaker Pro Advanced, è possibile impostare e modificare le opzioni.

Per modificare un'origine dati ODBC:

1. Selezionare il menu File > Gestisci > Origini dati esterne.

2. Selezionare l'origine dati ODBC dalla lista e fare clic su Modifica.

3. È possibile cambiare il nome dell'origine dati, specificare un DSN diverso, impostare le opzioni di autenticazione per accedere ad un'origine dati ODBC denominata, oppure impostare le opzioni di visualizzazione.

4. Per Autenticazione, l'opzione predefinita è Richiedi nome utente e password. Gli utenti devono inserire un nome utente e una password la prima volta che accedono alla tabella.

Per fare in modo che gli utenti non debbano inserire nome utente e password per accedere a questo file FileMaker, selezionare Specifica nome utente e password (da effettuare per tutti gli utenti) e inserire un nome utente e una password. È inoltre possibile creare un calcolo per determinare l'accesso dell'utente alla tabella esterna. In questi calcoli non è possibile utilizzare le variabili o i campi. Vedere Finestra di dialogo Specifica il calcolo per ulteriori informazioni sull'impostazione dei calcoli.

Se si lavora con file di database condivisi che accedono ai dati ODBC da Microsoft SQL Server e si desidera abilitare il single sign-on (SSO) per l'origine dati ODBC, selezionare Usa autenticazione di Windows (Single Sign-on) e inserire l'SPN (Service Principal Name). Vedere Abilitazione del single sign-on (SSO) per le origini dati ODBC (solo Windows).

Nota  FileMaker crittografa le password. Tuttavia, la crittografia sulle origini dati dipende dal supporto o meno della crittografia da parte del driver ODBC.

5. Per migliorare le prestazioni è possibile filtrare la lista delle tabelle esterne o le visualizzazioni che è possibile aggiungere al grafico delle relazioni. L'impostazione predefinita prevede di elencare tutte le tabelle dall'origine dati.

Per Nome catalogo, inserire un nome. In caso contrario, vengono elencate le tabelle di tutti i cataloghi.

Per Nome schema, inserire un nome. In caso contrario, vengono elencate le tabelle di tutti gli schemi.

Per Nome tabella, inserire un nome per elencare soltanto tale tabella.

6. È possibile filtrare la lista di tabelle per tipo: Tabelle, Visualizzazioni, o Tabelle di sistema.

Nota  Per includere altri tipi, deselezionare tutte le opzioni Filtra per tipo.

Impostazione di una tabella ODBC nel grafico delle relazioni

Dopo aver aggiunto un'origine dati ODBC, è possibile lavorare con le tabelle ODBC nel grafico delle relazioni e sui formati come avviene per le altre tabelle FileMaker. È possibile recuperare, aggiungere, aggiornare ed eliminare dati nella tabella ODBC in modo interattivo, in tempo reale.

1. Selezionare il menu File > Gestisci > Database.

2. Nella scheda Relazioni nella finestra Gestisci database fare clic su Pulsante Aggiungi tabella.

3. Nella finestra di dialogo Specifica tabella, per Origine dati scegliere Origine dati ODBC.

4. Se richiesto, inserire il nome utente e la password dell'origine dati ODBC.

5. Viene visualizzato un elenco delle tabelle esterne per tale origine dati.

6. Selezionare la tabella desiderata e fare clic su OK.

La tabella esterna appare nel grafico delle relazioni. Il nome della tabella è visualizzato in corsivo. Per informazioni sui collegamenti e sull'utilizzo delle tabelle nel grafico delle relazioni, vedere Utilizzo del grafico delle relazioni.

Suggerimento  Per determinare se una tabella nel grafico delle relazioni è una tabella FileMaker oppure di un'origine dati ODBC, spostare il puntatore sopra la freccia nell'intestazione della tabella. Per identificare più facilmente le tabelle ODBC è possibile assegnare ad esse un colore.

Dopo aver aggiunto una tabella al grafico delle relazioni, FileMaker aggiunge un formato con tale nome di tabella al menu a tendina Formato e la tabella viene elencata nella scheda Tabelle. Il nome della tabella è visualizzato in corsivo.

Le colonne della tabella ODBC sono visualizzate nella scheda Campi. I nomi dei campi sono visualizzati in corsivo. È possibile rimuovere i campi se non si desidera che FileMaker Pro Advanced li visualizzi all'interno della soluzione. Queste colonne non vengono rimosse dallo schema di tabella dell'origine dati SQL esterna, ma solo dalla rappresentazione di FileMaker Pro Advanced di tale schema di tabella. Per ulteriori informazioni, vedere Aggiornamento dei dati tra FileMaker e origini dati ODBC.

Prima di iniziare a lavorare con origini dati ODBC

Stabilire se lavorare con le tabelle ODBC in modo interattivo nel grafico delle relazioni o attraverso importazioni ODBC "statiche". Per un riepilogo dei diversi modi di lavorare con le origini dati ODBC, vedere Utilizzo di ODBC e JDBC con FileMaker Pro Advanced.

Determinare le tabelle a cui accedere e le origini dati in esse contenute.

Se FileMaker non è in grado di determinare automaticamente una chiave primaria della tabella, verrà richiesto di selezionare le colonne che comprendono una chiave univoca. In FileMaker ogni tabella deve avere una o più colonne che hanno un valore univoco per ogni riga.

Limitazioni sull'utilizzo delle origini dati ODBC

Non è possibile modificare lo schema delle origini dati ODBC. Tuttavia è possibile aggiungere dei campi supplementari per eseguire i calcoli e i riassunti sui dati da tabelle ODBC.

I campi delle origini dati ODBC possono essere utilizzati nelle liste valori, ma gli oggetti CLOB (Character Large Object), come le lunghe stringhe di testo, non sono supportati.

Per le liste valori con dati ODBC, il privilegio Nessun accesso e il privilegio personalizzato Limitato non sono supportati. Per impedire ad un utente la visualizzazione dei dati ODBC in una lista valori è necessario applicare una protezione a livello di riga nel database SQL esterno. Vedere Modifica dei privilegi per le liste valori.

I dati di tipo Indicatore data e ora di SQL Server non sono supportati.

Gli oggetti binari di grandi dimensioni (BLOB) come le immagini e i suoni non sono supportati.

Quando si lavora con tabelle esterne nella scheda Campi della finestra di dialogo Gestisci database, le seguenti opzioni di campo non sono supportate. Vedere Impostazione delle opzioni per i campi per informazioni sulle opzioni dei campi.

Nella scheda Immissione automatica, è possibile immettere automaticamente numeri di serie quando si creano record, ma non quando li si salvano. (Il database esterno determina il modo in cui i record vengono salvati). Quando vi è un riferimento ai dati correlati in un'origine dati ODBC, copia valore inferiore e copia valore superiore sono disabilitati.

Sulla scheda Verifica, Valore unico e Valore esistente sono disabilitati. Il Numero massimo di caratteri consentito in un campo è determinato dall'origine dati esterna.

La scheda Memorizzazione è disabilitata.

FileMaker non può controllare la verifica e altre opzioni impostate dagli amministratori ODBC. Vedere Aggiornamento dei dati tra FileMaker e origini dati ODBC per informazioni sul modo in cui le opzioni dei campi sono influenzate dalle operazioni di Sinc.

I file FileMaker collegati a origini dati ODBC non ereditano le relazioni create nelle origini dati ODBC.

Note 

È possibile applicare la formattazione condizionale ai dati dai campi esterni. Vedere Definizione della formattazione condizionale per gli oggetti del formato.

Quando i database ospitati da FileMaker Server o FileMaker Cloud for AWS sono collegati a origini dati ODBC, non è necessario che i client FileMaker impostino un DSN per accedere all'origine dati esterna. Tuttavia, il DSN deve essere impostato sulla macchina su cui è in esecuzione FileMaker Server o in FileMaker Cloud for AWS.

FileMaker non utilizza la semantica SQL sulle query. FileMaker può eseguire una query per ogni tabella correlata su un formato. Per mantenere determinati comportamenti di unione SQL o ottenere i risultati di predicati SQL quali GROUP BY, creare visualizzazioni. Quindi accedere ai dati da FileMaker attraverso tali visualizzazioni. (A volte le visualizzazioni sono chiamate "tabelle virtuali".)

Le query lunghe, i tentativi di scorrere l'intera tabella ODBC o l'apertura di una tabella grande possono provocare un rallentamento delle prestazioni.

Microsoft SQL Server: Per impostazione predefinita, i dati DATETIME, DATETIME2 e SMALLDATETIME dalle tabelle ODBC vengono importati come il tipo di campo Indicatore data e ora. È possibile cambiare il tipo di campo di un campo Indicatore data e ora ombra in un campo Data o Ora, ma i dati devono essere strutturati in un modo specifico. Se la tabella ODBC importata contiene dati Indicatore data e ora e il campo Indicatore data e ora viene considerato come un campo Data, la parte dell'ora deve corrispondere a 12:00 AM (o mezzanotte) per tutti i record nella tabella. Analogamente, se si importa una tabella ODBC che contiene dati Indicatore data e ora e il campo Indicatore data e ora viene considerato come un campo Ora, la parte della data deve corrispondere a 1900-01-01 (o 1 gennaio 1900) per tutti i record della tabella.

Come per qualsiasi tabella ODBC, se il campo è una chiave primaria e i valori non sono univoci, i risultati potrebbero essere incoerenti.