Utilizzo degli strumenti avanzati > Informazioni sulla creazione di soluzioni runtime > Differenze tra applicazione runtime e FileMaker Pro Advanced
 

Differenze tra applicazione runtime e FileMaker Pro Advanced

Nota  Questa sezione descrive le funzioni disponibili se è selezionata la preferenza generale Utilizza strumenti avanzati. Vedere Utilizzo degli strumenti avanzati.

Quando si fa doppio clic sull'icona di FileMaker Pro Advanced per avviare l'applicazione, è possibile creare una nuova soluzione o sceglierne una da aprire. Quando si avvia un'applicazione runtime di FileMaker Pro Advanced, si apre automaticamente il file primario associato.

Altre differenze fondamentali tra l'applicazione runtime e FileMaker Pro Advanced:

Tutte le funzioni di progettazione del database sono state rimosse o nascoste nell'applicazione runtime.

Fra queste vi sono il modo Formato scheda e i comandi del sottomenu Gestisci.

Le funzioni personalizzate e i menu personalizzati funzionano nell'applicazione runtime, anche se gli utenti non possono modificare o creare nuove funzioni o nuovi menu personalizzati.

Alcuni comandi di menu sono stati rimossi dall'applicazione runtime.

Ad esempio, non è possibile utilizzare l'applicazione runtime per creare, aprire o chiudere una soluzione. (Le soluzioni runtime associate devono contenere un pulsante o uno script personalizzato per chiudere o aprire altri file. Non esiste un comando di chiusura nella finestra di una soluzione runtime).

I plug-in possono essere abilitati nella finestra di dialogo Preferenze. L'opzione Consenti alle soluzioni di installare file nelle preferenze dei plug-ins consente l'installazione automatica degli aggiornamenti dei plug-in. Vedere Impostazione delle preferenze dei plug-in.

Anche se il filtro dati XML viene visualizzato come opzione nell'istruzione di script Converti file, non è possibile convertire i file XML utilizzando questa istruzione in un'applicazione runtime.

L'applicazione runtime FileMaker è per soluzioni per singoli utenti. Pertanto, la condivisione peer-to-peer in rete di soluzioni runtime non è possibile. Per permettere a più utenti di accedere alla stessa soluzione runtime, è necessario aprire la soluzione runtime in FileMaker Pro Advanced o FileMaker Server.

macOS: gli Apple Event sono supportati nelle applicazioni runtime.

Inoltre, le applicazioni runtime non supportano:

la possibilità di salvare/inviare i record come file PDF

gli strumenti avanzati

Se un database runtime è aperto in FileMaker Pro Advanced, gli strumenti avanzati sono disponibili (a meno che non siano stati rimossi i privilegi di accesso completo).

le origini dati SQL esterne (ESS), l'importazione ODBC o l'istruzione di script Esegui SQL

i grafici

gli account dei provider di identità OAuth

le funzioni JSON (vedere Utilizzo delle funzioni JSON)

la definizione di opzioni cURL nell'istruzione di script Inserisci da URL

funzioni di firma digitale RSA (vedere funzione CryptGenerateSignature e funzione CryptVerifySignature)

Preferenze dell'applicazione e del documento

Nell'applicazione runtime, alcune opzioni non sono disponibili nella scheda Generale della finestra di dialogo Preferenze. Ad esempio, non sono presenti le opzioni che consentono di notificare all'utente la disponibilità di un aggiornamento o di una nuova versione di FileMaker Pro Advanced.

La scheda Formato non è inclusa nella finestra di dialogo Preferenze dell'applicazione runtime.

La finestra di dialogo Opzioni file nell'applicazione runtime visualizza solo la scheda Ortografia.

Confronto dei comandi di menu

Le seguenti tabelle mostrano i comandi di menu disponibili in FileMaker Pro Advanced e nell'applicazione runtime.

 

Comando del menu File

FileMaker Pro Advanced in Windows

Runtime in Windows

FileMaker Pro Advanced in macOS

Runtime in macOS

Crea nuovo

X

 

X

 

Preferiti

X

 

X

 

Recente

X

 

X

 

Host

X

 

X

 

Apri

X

 

X

 

Chiudi

X

X

X

X

Gestisci

X

 

X

 

Condivisione

X

 

X

 

Opzioni file

X

X

X

X

Modifica password

X

X

X

X

Impostazioni di stampa

X

X

 

 

Imposta pagina

 

 

X

X

Stampa

X

X

X

X

Importa record

X

X

X

X

Esporta record

X

X

X

X

Salva/Invia record come

X

1

X

1

Invia

X

2

X

2

Salva copia con nome

X

X

X

X

Recupera

X

3

X

3

Esci

X

X

 

 

1. Non è possibile salvare/inviare record come PDF o snapshot link. Tuttavia, gli utenti macOS possono stampare il record corrente su PDF selezionando il menu File > Stampa.

2. Non è possibile inviare un link al database.

3. Premere Ctrl+Maiusc (Windows) o Opzione-Comando (macOS) mentre si avvia una soluzione runtime. Vedere Recupero dei file runtime.

 

Comando del menu Modifica

FileMaker Pro Advanced in Windows

Runtime in Windows

FileMaker Pro Advanced in macOS

Runtime in macOS

Annulla/Impossibile annullare

X

X

X

X

Ripeti/Impossibile ripetere

X

X

X

X

Taglia

X

X

X

X

Copia

(Copia tutti i record)

X

X

X

X

Incolla

X

X

X

X

Incolla solo testo

1

1

X

X

Cancella

X

X

X

X

Duplica

X

 

X

 

Seleziona tutto

(Seleziona tutti i record)

X

X

X

X

Trova/Sostituisci

X

X

X

X

Ortografia

X

X

X

X

Esporta contenuto campo

X

X

X

X

Preferenze

X

X

 

 

1. Non visibile nel menu, ma accessibile tramite Ctrl+Maiusc+V.

 

Comando del menu Visualizza

FileMaker Pro Advanced in Windows

Runtime in Windows

FileMaker Pro Advanced in macOS

Runtime in macOS

Modo Usa

X

X

X

X

Modo Trova

X

X

X

X

Modo Formato scheda

X

 

X

 

Modo Anteprima

X

X

X

X

Vai a formato

X

X

X

X

Visualizza come modulo

X

X

X

X

Visualizza come lista

X

X

X

X

Visualizza come tabella

X

X

X

X

Barra degli strumenti

X

X

X

X

Personalizza barra strumenti stato

X

X

X

X

Barra di formattazione

X

X

X

X

Righello

X

X

X

X

Zoom avanti

X

X

X

X

Zoom indietro

X

X

X

X

 

Comando del menu Inserisci

FileMaker Pro Advanced in Windows

Runtime in Windows

FileMaker Pro Advanced in macOS

Runtime in macOS

Immagine

X

X

X

X

Audio/Video

X

X

X

X

PDF

X

X

X

X

File

X

X

X

X

Data corrente

X

X

X

X

Ora corrente

X

X

X

X

Nome utente corrente

X

X

X

X

Dall'indice

X

X

X

X

Dal record visualizzato per ultimo

X

X

X

X

 

Comando del menu Formattazione

FileMaker Pro Advanced in Windows

Runtime in Windows

FileMaker Pro Advanced in macOS

Runtime in macOS

Carattere

X

X

X

X

Dimensione

X

X

X

X

Stile

X

X

X

X

Allineamento testo

X

X

X

X

Interlinea

X

X

X

X

Colore testo

X

X

X

X

 

Comando del menu Record

FileMaker Pro Advanced in Windows

Runtime in Windows

FileMaker Pro Advanced in macOS

Runtime in macOS

Nuovo record

X

X

X

X

Duplica il record

X

X

X

X

Elimina record

X

X

X

X

Elimina i record trovati/Elimina tutti i record

X

X

X

X

Vai al Record

X

X

X

X

Aggiorna finestra

X

X

X

X

Mostra tutti i record

X

X

X

X

Mostra solo le omissioni

X

X

X

X

Ometti il record

X

X

X

X

Ometti più record

X

X

X

X

Modifica l'ultima ricerca

X

X

X

X

Ricerche salvate

X

X

X

X

Ordina i record

X

X

X

X

Annulla l'ordinamento

X

X

X

X

Sostituisci contenuto campo

X

X

X

X

Nuovo riferimento contenuto campo

X

X

X

X

Ripristina il record

X

X

X

X

 

Comando del menu Richieste (modo Trova)

FileMaker Pro Advanced in Windows

Runtime in Windows

FileMaker Pro Advanced in macOS

Runtime in macOS

Aggiungi nuova richiesta

X

X

X

X

Duplica record

X

X

X

X

Elimina richiesta

X

X

X

X

Vai a Richiesta

X

X

X

X

Mostra tutti i record

X

X

X

X

Esegui la ricerca

X

X

X

X

Limita gruppo trovato

X

X

X

X

Amplia gruppo trovato

X

X

X

X

Ripristina richiesta

X

X

X

X

 

Comando del menu Script

FileMaker Pro Advanced in Windows

Runtime in Windows

FileMaker Pro Advanced in macOS

Runtime in macOS

<nomi script>

X

X

X

X

Nota  Tutti gli altri comandi del menu Script sono disponibili solo in FileMaker Pro Advanced.

 

Comando del menu Finestre

FileMaker Pro Advanced in Windows

Runtime in Windows

FileMaker Pro Advanced in macOS

Runtime in macOS

Nuova finestra

X

X

X

X

Mostra finestra

X

X

X

X

Nascondi finestra

X

X

X

X

Riduci finestra

X

X

X

X

Affianca orizzontalmente

X

X

X

X

Affianca verticalmente

X

X

X

X

Sovrapponi finestre

X

X

X

X

Porta tutto in primo piano

X

X

X

X

<Nomi delle finestre aperte>

X

X

X

X

 

Comando del menu Aiuto

FileMaker Pro Advanced in Windows

Runtime in Windows

FileMaker Pro Advanced in macOS

Runtime in macOS

Guida di FileMaker Pro Advanced

X

 

X

 

Scelte rapide da tastiera

X

 

X

 

Risorse di apprendimento

X

 

X

 

Documentazione prodotto

X

 

X

 

Consulenti e soluzioni

X

 

X

 

Fornisci feedback a FileMaker

X

 

X

 

Controllo aggiornamenti

X

 

X

 

Registra FileMaker Pro Advanced

X

 

X

 

FileMaker Community

X

 

X

 

Assistenza e supporto

X

 

X

 

Info su FileMaker Pro Advanced

X

 

1

 

Info su FileMaker Pro Advanced Runtime
(Visualizzato se non è stato specificato uno script personalizzato Info su)

 

X

 

1

Info su <soluzione runtime>
(Visualizzato se è stato specificato uno script personalizzato Info su)

 

X

 

1

<nome dello script Guida della soluzione runtime>
(Visualizzato se è stato specificato uno script Guida personalizzato)

 

X

 

X

1. Vedere la tabella dei comandi del menu Applicazione.

 

Comando del menu Applicazione (macOS)

FileMaker Pro Advanced

Runtime

Info su FileMaker Pro Advanced

X

 

Info su FileMaker Pro Advanced Runtime
(Visualizzato se non è stato specificato uno script personalizzato Info su)

 

X

Info su <soluzione runtime>
(Visualizzato se è stato specificato uno script personalizzato Info su)

 

X

Preferenze

X

X

Servizi

X

X

Nascondi FileMaker Pro Advanced

X

 

Nascondi <soluzione runtime>

 

X

Nascondi altri

X

X

Mostra tutto

X

X

Esci da FileMaker Pro Advanced

X

 

Esci da <soluzione runtime>

 

X

Istruzioni di script ignorate

Poiché alcune funzioni sono state rimosse dall'applicazione runtime, alcune istruzioni di script vengono ignorate dall'applicazione runtime. Le istruzioni di script ignorate sono contrassegnate con "No" o "In parte" in "Soluzione runtime" nella sezione Compatibilità della descrizione di ogni istruzione di script. Vedere Istruzioni di script.

Nota  Apri file restituisce un errore se il file specificato non è stato associato all'applicazione runtime. Una soluzione runtime può eseguire uno script esterno solo se il file esterno è associato alla soluzione runtime.

Impostazioni o preferenze memorizzate dell'applicazione runtime

L'applicazione runtime memorizza le impostazioni (Windows) o preferenze (macOS) di registro nella seguente posizione.

Windows: HKEY_CURRENT_USER\Software\FileMaker\<nome soluzione>\18.0

Nota  L'estensione dei file di database runtime è registrata in HKEY_CLASSES_ROOT.

macOS: com.filemaker.client.runtime.<nome soluzione>.plist