Automatizzazione delle attività con gli script > Creazione e modifica degli script
 

Creazione e modifica degli script

Nota  Per informazioni su ciascuna istruzione di script e su relative opzioni ed esempi, vedere Istruzioni di script (in ordine alfabetico) e Istruzioni di script (per categoria). Vedere anche Esempi di script.

Per creare o modificare uno script:

1. Selezionare il menu Script > Area di lavoro script.

Oppure, selezionare il menu File > Gestisci > Script.

Si apre la finestra Area di lavoro script. È possibile creare e modificare gli script utilizzando i tre pannelli di questa finestra: il pannello script (a sinistra), il pannello modifica script (al centro) e il pannello istruzioni script (a destra).

2. Creare o aprire uno script:

Per creare uno script, fare clic su Pulsante Guida/Aiuto. Nel pannello modifica script, digitare un nome per il nuovo script e premere Invio o Ritorno.

Per visualizzare l'anteprima di uno script, fare clic sul nome dello script nel pannello script. Fare clic su Pulsante Calcolo per passare dall'anteprima alla modifica dello script.

Per modificare uno script, fare doppio clic sul nome dello script nel pannello script. Se lo script è già aperto nel pannello modifica script, fare clic sulla scheda dello script per attivarla.

3. Iniziare a digitare il nome dell'istruzione di script, quindi scegliere l'istruzione di script dall'elenco che viene visualizzato.

Oppure fare doppio clic sull'istruzione di script nel pannello istruzioni script.

4. Se l'istruzione di script ha opzioni, indicate da testo racchiuso tra parentesi quadre ([ ]) o da Pulsante menu Azione accanto all'istruzione di script, eseguire una delle seguenti operazioni:

Fare clic sul testo tra parentesi, quindi specificare le opzioni visualizzate.

Fare clic su Pulsante menu Azione, quindi specificare le opzioni visualizzate.

Fare clic tra le parentesi e modificare il calcolo o fare clic su Pulsante Ordine per categoria per aprire la Finestra di dialogo Specifica il calcolo. Solo alcuni calcoli sono modificabili in linea.

Nota  Mentre si modifica un'istruzione di script, è possibile che venga visualizzata l'opzione Ripristina. Ripristina indica che i criteri specificati all'ultima modifica dell'istruzione di script verranno utilizzati all'esecuzione dell'istruzione di script.

5. Eseguire una delle seguenti operazioni mentre si lavora nel pannello modifica script:

 

Per

Eseguire questa operazione

Aggiungere una riga allo script

Eseguire una delle seguenti operazioni:

Premere Invio o Ritorno.

Se l'ultima riga dello script non è vuota, selezionare l'ultima riga e premere la freccia in giù.

Aggiungere una riga sopra a quella selezionata

Premere Maiusc+Invio o Maiusc-Ritorno.

Spostarsi tra le righe di uno script

Premere la freccia in su o la freccia in giù.

Aggiungere un commento a uno script

Su una riga vuota, digitare # o selezionare Commento dal pannello istruzioni script. L'utilizzo dell'istruzione di script # (commento) in uno script ne semplifica la comprensione da parte degli altri utenti che lo visualizzano o lo modificano.

Aggiungere un'istruzione di script alla categoria Preferiti

Nel pannello istruzioni script, selezionare l'istruzione di script e fare clic su Pulsante menu Gestisci script. Per rimuovere un'istruzione di script dalla categoria Preferiti, selezionare l'istruzione di script e fare clic su Pulsante Stella grigia.

Nota  Non è possibile aggiungere un'istruzione di script alla categoria Preferiti se il pannello istruzioni script è ordinato alfabeticamente.

Visualizzare le informazioni su un'istruzione di script

Nel pannello istruzioni script, fare clic sull'istruzione di script. Sotto l'elenco, viene visualizzata una descrizione. Per visualizzare più informazioni, fare clic su Pulsante Compatibilità.

Visualizzare le istruzioni di script in ordine alfabetico o per categoria

Nel pannello istruzioni script, fare clic su Pulsante Esegui script per visualizzare le istruzioni di script in ordine alfabetico o su Pulsante menu Gestisci script per ordinarle in base alla categoria.

Vedere quali prodotti FileMaker supportano un'istruzione di script

Fare clic su Pulsante Nuova cartella e selezionare un prodotto. Vengono visualizzate tutte le istruzioni di script che sono compatibili con il prodotto.

Copiare e incollare un'istruzione di script

Vedere Copia e incolla di script.

Duplicare un'istruzione di script

Selezionare l'istruzione di script, quindi selezionare il menu Modifica > Duplica (Windows) o Duplica istruzione (macOS).

Eliminare un'istruzione di script

Selezionare l'istruzione di script, quindi premere Elimina.

Riordinare le istruzioni di script nello script

Trascinare l'istruzione di script nel pannello modifica script in una nuova posizione nello script.

Selezionare più istruzioni di script

Fare clic tenendo premuto Ctrl (Windows) o Comando (macOS). È possibile aggiungere, duplicare o eliminare più istruzioni.

Aprire uno script incluso nell'opzione di un'istruzione di script

Fare clic sull'opzione dell'istruzione di script tenendo premuto Ctrl (Windows) o Comando (macOS).

Eseguire lo script

Fare clic su Pulsante Compatibilità.

Nota  Un asterisco (*) accanto al nome di uno script indica che lo script è stato modificato ma non salvato.

6. Chiudere la scheda, quindi fare clic su Salva.

Oppure selezionare il menu File > Salva script nell'Area di lavoro script (Windows) o il menu Script > Salva script nella barra dei menu di FileMaker Pro Advanced (macOS).

Per gestire gli script:

 

Per

Eseguire questa operazione

Rinominare, duplicare o eliminare uno script

Fare clic con il tasto destro del mouse sul nome dello script e selezionare una voce dal menu. È anche possibile fare doppio clic sul nome dello script nel pannello modifica script per rinominarlo.

Riordinare gli script

Trascinare il nome dello script in una nuova posizione nell'elenco.

Stampare uno script

Windows: nell'Area di lavoro script, selezionare il menu File > Stampa script.

macOS: nella barra dei menu di FileMaker Pro Advanced, selezionare il menu File > Stampa.

Eseguire uno script con privilegi di accesso completo

Fare clic con il tasto destro del mouse sullo script e selezionare Garantisci privilegi di accesso completo. Vedere "Esecuzione degli script con privilegi di accesso completo" di seguito.

Gestire le cartelle nel pannello script

Vedere Gestione degli script utilizzando le cartelle.

Esecuzione degli script con privilegi di accesso completo

Impostare uno script perché venga eseguito con privilegi di accesso completo permette agli utenti che dispongono di privilegi e accesso limitati di eseguire operazioni che altrimenti non potrebbero effettuare, come ad esempio esportare o eliminare record.

I privilegi di accesso non cambiano, ma allo script sono assegnati più privilegi rispetto all'utente. Inoltre, l'accesso completo non viene trasferito agli eventuali subscript, a meno che non sia stata attivata anche questa funzione per lo script.

Gli script possono essere impostati per essere eseguiti con privilegi di accesso completo solo dagli utenti che dispongono del set di privilegi Accesso completo. Solo gli utenti che dispongono di privilegi di accesso completo possono modificare o eliminare gli script per cui è stata attivata questa funzione.

Uno script può essere eseguito con privilegi di accesso completo soltanto nel file in cui è stato definito. Gli script non possono superare le limitazioni di accesso ai file esterni. Ad esempio, uno script impostato per essere eseguito con privilegi di accesso completo non può eliminare i record di un file esterno ad accesso limitato.

Agli utenti con privilegi di accesso completo può essere consentito di modificare gli script contrassegnati come modificabili in base al loro set di privilegi. Per creare, duplicare, importare e/o eliminare gli script sono necessari privilegi di accesso completi.

Note 

Per verificare i problemi durante la creazione di uno script, fare clic con il tasto destro del mouse sulla scheda nel pannello modifica script e selezionare Verifica problemi. FileMaker Pro Advanced verifica lo script ed evidenzia le righe con eventuali problemi, come opzioni mancanti. (non è possibile rilevare tutti i problemi). Le righe vengono evidenziate nel colore Problema predefinito riportato nella scheda Colorazione della sintassi della finestra Preferenze Area di lavoro script.

Per modificare la codifica dei colori per le istruzioni di script e le condizioni come i problemi, nell'Area di lavoro script, selezionare il menu Visualizza > Preferenze (Windows) o il menu Visualizza > Preferenze Area di lavoro script (macOS) e fare clic sulla scheda Colorazione della sintassi.

Per modificare uno script in una nuova finestra, fare clic con il tasto destro del mouse su una scheda del pannello modifica script e selezionare Sposta scheda in una nuova finestra oppure premere Alt (Windows) o Opzione (macOS) e fare doppio clic su uno script nel pannello script. Lo script si apre nella finestra di dialogo Modifica script.

Per permettere l'esecuzione dello script con privilegi di accesso completo, selezionare il menu File > Garantisci privilegi di accesso completo (Windows) o il menu Script > Garantisci privilegi di accesso completo (macOS).

Se l'accesso alla finestra di dialogo Modifica script è stato eseguito convertendo un'azione pulsante in uno script, è possibile premere Ctrl+R (Windows) o Comando-R (macOS) per rinominare lo script.

Argomenti correlati 

Utilizzo di operatori nelle formule

Istruzioni di script (per categoria)

Istruzioni di script (in ordine alfabetico)

Utilizzo dei pulsanti e delle barre dei pulsanti nei formati

Utilizzo del menu Script

Modifica dei privilegi per gli script

Pubblicazione dei database sul Web

Debug degli script

Disattivazione delle istruzioni di script