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Chapter 1
Introducing FileMaker Pro Advanced
Welcome to FileMaker® Pro Advanced. This product includes advanced development and
customization tools designed especially for database developers. You can use either
FileMaker Pro or FileMaker Pro Advanced to create and test your database solutions.
In addition to all of the features that are available with FileMaker Pro, FileMaker Pro Advanced
includes:

1 Developer Utilities, for creating, customizing, and deploying runtime database solutions
1 Database Design Report feature, for publishing comprehensive documentation on structures or
schemas of databases

1 Script Debugger, for systematic testing and debugging of FileMaker scripts
1 Data Viewer, for monitoring fields, variables, and calculations
1 Copy feature, for copying fields or tables. You can also import table schema for use within the
same file or across different files.

1 Custom Menus feature, for creating customized menus for the solution
1 Custom Functions feature, for creating custom functions for use anywhere within the solution

About this guide
This Development Guide includes information about features that are available with FileMaker Pro
Advanced.
See FileMaker Pro Help for detailed information on product features.
To send your feedback on this guide, visit:
http://www.filemaker.com/company/documentation_feedback.html.
To access resources on the FileMaker website such as ready-made solutions and the FileMaker
Knowledge Base, choose Help menu > Resource Center.
To learn more about FileMaker Pro and discuss support topics with other customers, visit the
FileMaker Forum. Choose Help menu > FileMaker Forum.

Using the FileMaker Pro Advanced documentation
This Development Guide is one component in a comprehensive documentation suite provided
with FileMaker Pro Advanced. FileMaker Pro Advanced also includes an online Help system to
provide details on FileMaker Pro features.
This guide assumes that you are familiar with FileMaker Pro or FileMaker Pro Advanced, and that
you have created a database solution that you want to work on using the FileMaker Pro Advanced
features. If you are new to the FileMaker family, start with the FileMaker Pro User’s Guide.
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The following manuals are included:

1 FileMaker Pro Advanced Development Guide (this manual): describes how to use the features
available in FileMaker Pro Advanced

1 Installation and New Features Guide for FileMaker Pro and FileMaker Pro Advanced: contains
installation instructions and a list of the new features in the current version

1 FileMaker Pro User’s Guide: contains key concepts and basic procedures
1 FileMaker Pro Tutorial: contains step-by-step lessons that teach you how to create and use
FileMaker Pro databases

1 FileMaker Pro Advanced Database Design Report XML Output Grammar manual: describes

the FileMaker Pro Advanced Database Design Report (DDR) XML output grammar for users
who want to create tools that analyze or process the structure of databases

1 FileMaker Instant Web Publishing Guide: describes how to make FileMaker Pro and

FileMaker Pro Advanced databases accessible to web browser users over an intranet or the
internet

1 FileMaker ODBC and JDBC Guide: describes how you can use FileMaker software as an
ODBC client application and as a data source for ODBC and JDBC applications.

Where to find PDF documentation
To access PDFs of FileMaker documentation:

1 in FileMaker Pro Advanced, choose Help menu > Product Documentation
1 visit http://www.filemaker.com/documentation for additional documentation

Abiding by the license agreement for runtime solutions
The FileMaker Pro Advanced license agreement allows you royalty-free distribution of an
unlimited number of FileMaker Pro runtime database solutions. However, there are several terms
and conditions in the license agreement you must abide by, including the following:

1 You must provide all of the end-user technical support.
1 You must provide an “About” layout that includes your name, address, and the telephone

number for your technical support. For more information about creating an About layout, see
“Your responsibilities as a developer” on page 7.

1 You must read and agree to the terms and conditions of the FileMaker Pro Advanced license
agreement, available through the FileMaker Pro Advanced installer, before using the
FileMaker Pro Advanced software.
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Your responsibilities as a developer
FileMaker, Inc. has established procedures for repairing files. If a customer complies with these
procedures, then FileMaker may supply a repaired file to the customer.
Note FileMaker does not recover account names and passwords.
If you distribute database files with passwords or you have removed full access privileges and do
not want FileMaker to repair a file for a customer who requests this service, you must:
1. Notify your customers in writing and keep a record of such notice that your database solution
contains passwords or data that can only be provided by you.
2. Every file in your runtime database solution must contain an About layout accessible from any
layout in the database.
3. The layout name must begin with the word “About.”
4. The About layout must contain these items:

1 solution name
1 your company name and contact information
1 your support policy (for example, how and when you are available for technical support)
5. The About layout must contain this exact warning:
“USER WARNING: This database solution contains password(s) that can only be
provided by the Developer identified above.”
For more information about creating an About layout, see Help.
6. If full access privileges have been permanently removed from your database solution by
selecting the Remove admin access from files permanently option in the Developer Utilities,
then the About layout must contain this exact warning:
“USER WARNING: This file is not customizable. Contact the above named Developer for
information on customizing this database solution.”
The accounts and privileges protection in a FileMaker file should not be viewed as an absolute
barrier that will prevent a customer from accessing files. FileMaker cannot guarantee that a
customer will not be able to identify or bypass the password through third-party solutions or tools.
Therefore, FileMaker recommends that you take appropriate steps to protect your consulting and
development efforts without relying solely upon the password. For more information about
accounts and privileges, see Help.
If you have a dispute with your customer, you must resolve this dispute directly with the customer.
FileMaker is unable to, and will not, attempt to resolve such disputes.

Chapter 2
Creating database solutions
FileMaker Pro Advanced provides Developer Utilities that let you:

1 rename a set of database files and automatically update the internal links to related files and
scripts

1 bind your database files into a stand-alone runtime database solution that does not require
FileMaker Pro or FileMaker Pro Advanced in order to be used on a computer

1 remove administrative access from all accounts and prevent users from modifying most design
or structural elements of your databases

1 display your database files in Kiosk mode
1 add the FileMaker Pro filename extension to your files
Note See FileMaker Pro Help for detailed, comprehensive information and step-by-step
procedures about using FileMaker Pro Advanced.

Using the Developer Utilities
To customize your database files or bind the files to a runtime solution:
1. Close all of your database files that you are going to customize.
2. Choose Tools menu > Developer Utilities.
3. If you have used the Developer Utilities on the same database before and saved your settings,
click Load Settings.
A dialog box opens so that you can browse to find your settings file.
4. Click Add to locate the files that you want to customize.
5. If you are binding multiple files into a runtime solution, double-click a file in the list to specify the
primary file.
6. To rename a file, select the file in the list, type the new name in the Rename file box, and click
Change.
7. To remove a file, select the file in the list and click Remove.
8. Under Project Folder, click Specify to choose the location in which the copy of the database
solution will be saved.
9. If you do not want the new files to overwrite earlier versions, clear Overwrite matching files
within the Project Folder.
Important If Overwrite matching files within the Project Folder is selected, the Developer
Utilities will overwrite files with the same names as those in the list of files.
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10. Do one of the following:

1 If you want to create a copy of your database files with new names, click Create.
Note FileMaker Pro Advanced automatically updates internal links to related files and scripts.

1 If you want to further customize your database files or bind the files, under Solution
Options, click Specify.

11. In the Specify Solution Options dialog box, select one or more options:
To

Do this

Bind databases to runtime
applications

Select Create Runtime solution application(s).
Note This option can be combined with all others, except Databases must
have a FileMaker file extension.
See “About creating runtime solutions,”

Permanently prohibit any
administrative access to your
solution

Select Remove admin access from files permanently.
Important Once removed, administrative access cannot be restored to the
custom solution.
For more information about removing Admin access to databases, see Help.

Force accounts without full
access privileges to open your
solution in Kiosk mode

Select Enable Kiosk mode for non-admin accounts.
See “Creating Kiosk solutions” on page 16.

Add the FileMaker extension to
the filenames of database files

Select Databases must have a FileMaker file extension.
Note This option is not available if you select Create Runtime solution
application(s). You can use this feature to add extensions to files that do not
have extensions.

Create a log file to record any
errors encountered during
processing

Select Create Error log for any processing errors.
Specify a location and a filename for the error log.
Notes
1 If you don't specify a filename and location for the error log, it will be saved to
the project folder with the filename Logfile.txt.

1 If an error occurs during the processing of the options, the error is logged in
the error log. An error message may also indicate that an error has been
encountered.

12. Click OK.
13. To be able to quickly repeat the process, click Save Settings, and choose a folder and
location for your settings file. For more information about saving solution settings, see Help.
14. Click Create.

About creating runtime solutions
Use the Developer Utilities to produce a stand-alone runtime database solution that users can
access without running FileMaker Pro or FileMaker Pro Advanced. The Developer Utilities create
a copy of your files, and bind the database file or files to a runtime application with a name that
you specify.
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Runtime applications do not have all the functionality and features of FileMaker Pro. For a
complete list of the differences between the runtime application and FileMaker Pro, see
Appendix A, “Feature comparison of the runtime application with FileMaker Pro.”
You may need to bind your database files several times before you prepare them for delivery to
your users. When you have completed development and the final version is bound and ready to
distribute, you should thoroughly test your runtime solution to ensure that it behaves as expected.
Note FileMaker Pro and FileMaker Pro Advanced allow you to include as many database tables
as you need in a database file. This capability eliminates one of the main reasons for using
multiple files. However, other elements, like scripts and access privileges, are stored at the file
level and so some complex solutions will still benefit from using multiple files.
Before you begin to build your database solution, you need to decide how users will interact with
it. Your database solution might have any of the following components:

1 a primary database file that connects all of the auxiliary files
1 scripts and buttons to open auxiliary files, return to the primary file, display a splash screen
layout at startup, or quit a runtime application

1 common elements and a consistent appearance for cross-platform solutions
1
1
1
1

tooltips and custom menus
an About layout to introduce your solution (required)
a custom Help system that provides usage tips for your solution
multiple privilege sets that can specify levels of access to layouts, menus, specific tables,
record, fields, and so on

1 password-protected accounts assigned to privilege sets that determine the level of access of
account users

For information about what users need in order to use your runtime database solution, see
“Distributing runtime solutions” on page 12.

Converting and upgrading previous solutions
If you have developed a FileMaker Pro runtime database solution using the Solutions
Development Kit (SDK) for FileMaker Pro 3.0 or earlier, the Binder utility in the FileMaker Pro 4.0
Developer Edition, or the Developer Tool in FileMaker Developer 5.x and 6.0, you can upgrade
your solution and provide your users with the converted files. Files bound to a runtime application
using the earlier tools must be rebound using the Developer Utilities.
You must convert FileMaker Pro files created in earlier versions to FileMaker Pro 12 format. Files
created using versions prior to FileMaker Pro 7 must be converted to version 7, 8, 9, 10, or 11,
then converted to version 12. You can convert a single file or convert multiple files at once. For
more information about converting files, see Help.
After you have converted the files, you can upgrade them to take advantage of newer
FileMaker Pro and FileMaker Pro Advanced features. If necessary, create scripts to import users’
existing data from the old runtime database solution into the new, upgraded solution. See Help for
more information on importing data into upgraded runtime solutions. Use the Developer Utilities
to bind the solution files into a new, upgraded runtime database solution.
Distribute the new upgraded runtime database solution and provide instructions for how users can
upgrade their files by converting the old files in the new runtime application and importing their data.
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Binding the solution
To bind database files into a runtime database solution:
1. Follow the procedures in “Using the Developer Utilities” on page 8.
2. In the Specify Solution Options dialog box, select Create Runtime solution application(s).
3. To name your runtime application:

1 For Runtime Name, type a name. The name is used for the runtime application filename and
for the name of the folder that contains the runtime database solution files.

1 For Extension, type a one- to five-character filename extension. The extension is used to
associate the solution files with the runtime applications.

For more information about naming runtime solutions, see Help.
4. For Bindkey, type a key between 1 and 24 characters long.
The binding key links the runtime application to the database files and ensures that the bound
files will only open in the appropriate runtime application. The binding key is case-sensitive. For
more information on setting the binding key, see Help.
Important Binding installs system files pertaining to each platform. If your solution will be used
in Windows, bind it using the Developer Utilities for Windows. If your solution will be used on
Mac OS X, bind it using the Developer Utilities for Mac OS X. If you’re creating a solution to be
used on both Windows and the Mac OS X, create two separate runtime solutions by binding the
original solution files twice: once using FileMaker Developer Utilities for Windows, and again
using FileMaker Developer Utilities for Mac OS X. Use the same binding key on both platforms.
5. To add a company logo or other custom image to the closing splash screen, click Specify,
select the closing image, and click Select.
The image should be at least 32 x 175 pixels (72 dpi) or higher, otherwise it will be distorted
when displayed. The supported image formats are JPEG and GIF.
6. For Delay, set the number of seconds that you want the splash screen to display.
You can preview the effect that your custom splash screen will have by clicking the Preview
button.
7. Once you have specified options, click OK.
8. To be able to quickly repeat the process, click Save Settings, and choose a location for your
settings file.
For more information about saving and reusing Developer Utilities settings, see Help.
9. Click Create.
The Developer Utilities copy all of the runtime files to a new folder created inside the Project
Folder and named after the runtime solution.
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Starting runtime database solutions
Double-click to start
Runtime application icon

Solution file icon

Important Your users should start your solution by double-clicking the runtime application icon, not
the solution file icon. Double-clicking the icons for the solution or auxiliary files might result in errors,
depending on whether there are other copies of the runtime application on their hard disk. If your
users have more than one solution on their computers associated with the same one- to fivecharacter extension and they double-click the icon for the solution file, the first solution installed will
attempt to open the file, and this might not be the correct application for the specific file.

Distributing runtime solutions
The final steps in developing your runtime database solution are to bundle all of the necessary
files together, choose how you will distribute your solution—for example, on a CD-ROM or over a
network—and provide your users with documentation for installing your solution. In addition, your
documentation should include instructions for starting the runtime application and what to do if a
file is damaged.
Note Windows: The proper method for distributing Runtime solutions (including the executable)
is to use Installer software. This software must install components in the proper location in the
Windows filesystem and provide an uninstall capability. See the Microsoft website for information
about the location of installed files as well as location restrictions.

Organizing solution components
When you bind your database files into a runtime database solution, the Developer Utilities create
a new solution folder and place the runtime application, the bound primary and auxiliary database
files, and an Extensions folder inside it. For Windows runtime solutions, there are also required
Dynamic Link Library (DLL) files.
Note When you move multiple files into one folder to create a runtime solution, be aware that
your internal links are affected. For this reason, every data source must include a path that is just
the filename of the file being referenced. Although the runtime application will check other data
sources, it will then be able to find the file in the same folder in which it resides. You can still keep
any absolute or relative paths in the same data source reference in case the files are also used in
FileMaker Pro or FileMaker Pro Advanced.
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Windows solution folder

Mac OS X solution folder

Runtime application

Runtime application
package

Bound primary and
auxiliary solution files

Bound primary and
auxiliary solution files

DLLs generated during
binding

Extensions

Extensions

Dictionaries

Dictionaries
language
resource folders

Example of Windows and Mac OS X solution contents for distribution

Important These files and folders must not be renamed.
For details on the contents of the Mac OS X runtime application package and the Windows
Extensions folder and DLLs, see Help.
If your runtime database solution requires custom files, you should provide the files with the
runtime files. Plug-ins should be stored in the Extensions folder. If a developer uses a font not
found on a user’s system, the runtime application will make a font substitution. If a font is included
with the runtime, provision should be made for its installation through the installer program. See
“Using a custom installation program” below.
In addition to the runtime files, you will need to provide installation instructions for your users. For
more information on documenting developer solutions, see Help.

Choosing a distribution method
After you have organized the files that comprise your solution, you need to decide how your users
will install them. You can distribute your bundled solution on a CD-ROM, over a network, or via the
internet. In order to run your runtime database solution, your users will need the same minimum
equipment and software required by the FileMaker Pro Advanced application.
Using a custom installation program
You should use a custom installation program to package your runtime solution for installation by
users. Configuring a custom installation application to install runtime database solution files may
require more engineering than using a compression utility, but will help to ensure that your users
do not have difficulties installing your runtime solution.
Here are some custom installation applications you might want to use:

1 MindVision Installer VISE
1 InstallShield MultiPlatform
1 MacInstallerBuilder
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Using a compression utility program
If your runtime database solution is not complex and you have confidence in the technical
experience of your end users, you might consider a compression utility program rather than a
custom installation program.
Sharing solutions over a network
Users cannot share your runtime database solution over a network unless they access the files
using FileMaker Pro or FileMaker Pro Advanced installed on their machines. You must have a
master password to enable or change network access to the file. For optimal performance, you
can host the solution files using FileMaker Server.
For information about the FileMaker Server and FileMaker Pro products, and information about
volume license sales, visit the FileMaker website at http://www.filemaker.com.
Recovering damaged files
Power failures, hardware problems, or other factors can damage a FileMaker database file. If your
database solution becomes damaged, your users will need to recover the damaged file. When the
runtime application discovers a damaged file, a dialog box appears, telling the user to contact the
developer. Even if the dialog box does not appear, files can become corrupted and exhibit erratic
behavior.
For information about recovering runtime files, see Help.
Creating an About layout
For runtime database solutions, the FileMaker Pro Advanced license specifies that you must
create an About layout that provides information for your users on how to contact you for technical
support. FileMaker uses the About layout to distinguish databases created by developers using
FileMaker Pro Advanced rather than users of FileMaker Pro.
For more information about what is required to appear in the About layout for runtime database
solutions, see “Your responsibilities as a developer” on page 7.
Creating a custom Help layout
The FileMaker Pro Advanced Help system is not available in runtime applications.
Create a Help layout that provides instructions for how to use your custom solution and add data
to it. Then create a script in the primary file of your solution to display the Help system. Use the
custom menus feature to make the script available as a command in the Help menu.
To create a web page to document your solution, put a web viewer in your Help layout that opens
the web page.
For more information about creating and editing custom menus, see “About custom menus” on
page 20.
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Testing before and after creating your solution
You should verify the functionality of your database solution by testing it thoroughly before and
after you customize it with the Developer Utilities.
To ensure the quality of your custom database solution:

1 Verify every function and option in your solution. If you’re developing a solution for both
platforms, test it on both Windows and Mac OS X platforms.

1 Make sure your runtime database solution does not use a standard FileMaker Pro feature that
is hidden or disabled in the runtime application. See Appendix A, “Feature comparison of the
runtime application with FileMaker Pro.”

1 Verify that all scripts and buttons work as expected. This is especially important if you’re
displaying your solution in Kiosk mode. See “Creating Kiosk solutions” on page 16.

1 Verify your installation procedures and test other instructions in the documentation.
1 Verify that your database layouts display well on monitors with different color capabilities and
resolutions and on the smallest size monitor your users may be using.

1 Test your runtime database solution with actual data. This is especially important if users are
upgrading from earlier versions of the runtime application and need to import data into new
solution files.

1 Make sure all the auxiliary files and DLLs (Windows) are present.
1 Show your database solution to intended users to uncover any usability issues.
1 Install your bundled database files on a completely different computer to verify that all the files
associated with the primary file can be found.

1 If you’re assigning passwords or permanently removing full access privileges, test all access
levels.

1 Make sure your database solution contains an About layout that notifies users of the level of
access you’re providing.

Important You should keep an unbound version of any runtime database solution files,
especially if you’ve permanently removed full access privileges.

Distributing updates to runtime database solutions
If you make feature enhancements or modifications to the primary bound file of your runtime
database solution, you can distribute the updated file to your users without rebinding it. If you
change the filename of the primary file, however, you’ll need to rebind the file and distribute a new
version of the runtime application along with the updated file.
To distribute new or updated auxiliary files for your runtime database solution, bind them first using
the original binding key. If you are distributing a new auxiliary file that requires new data sources
in the main file or that requires other files to interact with it, you must update all files that have been
modified.
If you forget the original binding key for your runtime database solution and want to update or add
a file, you’ll need to rebind all of the database files with a new binding key and redistribute the
entire solution.
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To distribute an updated primary file:
1. Open the original primary file from your copy of the runtime solution in FileMaker Pro Advanced.
2. Make the changes to the primary file.
3. If necessary, create an Import script so users can import their existing data into the new primary file.
For more information about importing data into upgraded runtime solutions, see Help.
4. Send your users a copy of the new primary file with instructions to replace the old primary file
in the runtime database solution folder.
To distribute a new or updated auxiliary file:
1. In FileMaker Pro Advanced, create the new auxiliary file or open the original auxiliary file
(before it was bound) and make changes as required.
2. If necessary, create an Import script so users can import their existing data into the new file.
For more information about importing data into upgraded runtime solutions, see Help.
3. Use the Developer Utilities to rebind all of the files in the runtime database solution and include
the new or updated auxiliary file.
Use the same binding key that you used for the primary file.
4. Send your users a copy of the new or updated auxiliary file along with instructions to place it in
the runtime database solution folder, replacing the old file if appropriate.
As long as the binding key has not changed, you don’t need to redistribute the runtime
application or other solution files.

Creating Kiosk solutions
Kiosk mode is a way of displaying your database solution or your runtime database solution on a
full screen, without any toolbars or menus. As the name suggests, Kiosk mode can be used to
present your database to users as an information kiosk. You can design your database to run
through a touch screen.
Kiosk mode is ignored if the solution is opened by accounts with the Full Access privilege set, a
privilege set that allows management of extended privileges, or a privilege set that allows
modification of layouts, value lists, and scripts.
For your solution to display in Kiosk mode, you must:

1 create an account with a limited privilege set or create a specific Kiosk account.
1 enable Kiosk mode. At the same time that you enable Kiosk mode, you can bind the database
as a runtime solution.

1 clear the default option of logging into the file with the Admin account.
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To create a limited-access Kiosk account:
1. With the database solution open, choose File menu > Manage > Security.
2. In the Manage Security dialog box, click New.
3. In the Edit Account dialog box, type an account name.
4. For Account Status, click Active, and for Privilege Set, select New Privilege Set.
5. In the Edit Privilege Set dialog box, give the privilege set a name and description.
6. For Layouts, Value Lists, and Scripts, select either All view only or All no access.
7. Clear the Manage extended privileges checkbox.
8. Select other options as required and click OK until all dialog boxes are closed.
To enable Kiosk mode:
1. Follow the procedures in “Using the Developer Utilities” on page 8.
2. In the Specify Solution Options dialog box, select Enable Kiosk mode for non-admin accounts.
3. Select other options as required and click OK.
4. You can quickly repeat this process by clicking Save Settings and choosing a folder and
location for your settings file.
For information on saving solution settings, see Help.
5. Click Create.
If you did not bind the files to a runtime application, the Developer Utilities copy the selected
database files to the Project Folder. If you did bind the files to a runtime application, the
Developer Utilities copy all of the runtime files to a new folder created inside the Project Folder
and named after the runtime solution.
To change the default option of logging into the file with the Admin account:
1. With the database solution open, choose File menu > File Options.
2. In the Open tab, clear Log in using.
3. Click OK.
When you create a solution to run in Kiosk mode, you need to provide navigation for your solution
and the ability for users to quit your solution.
Note If you have a previous Kiosk solution that displayed the status area, you will need to update
your solution. You cannot display the status toolbar or layout bar in a Kiosk solution, so you need
to add record navigation, script paused status, and script Cancel and Continue buttons to your
layouts.
For more information on using scripts and buttons to control Kiosk solutions, see Help.

Chapter 3
Customizing database solutions
You can use FileMaker Pro Advanced to customize your solutions beyond what is possible with
FileMaker Pro. You can:

1
1
1
1
1

copy and paste fields for use within the same file or other database files
copy or import existing tables into your database file
create custom functions for use anywhere within a file
create custom menus
create plug-ins that extend the feature set of FileMaker Pro

Important You must have full access privileges to customize database solutions.
Note See Help for detailed, comprehensive information and step-by-step procedures about
using FileMaker Pro Advanced.

Copying or importing field and table schemas
You can copy or import field and table schemas within a file or to other database files.
With FileMaker Pro Advanced, you can consolidate tables from a multi-file solution into one file.
There are two methods for consolidating solutions:

1 Copy table schemas — Open source files to select and copy the tables you want. Then, paste
the table schemas into the destination file.

1 Import table schemas — Import table schemas directly into the destination file. You can import

just the schemas or import data with a single schema. (To import the data with a single schema,
choose File menu > Import Records > File.)

To

Do this

Copy a field schema

Choose File menu > Manage > Database > Fields tab. Select the field from the list, then
click Copy. Data is not copied.

Copy a table schema

Open the file that contains the table you want to copy. Choose File menu > Manage >
Database > Tables tab. Select the table from the list, then click Copy.

Import a table schema

Open the file into which you want to import a table. Choose File menu > Manage >
Database > Tables tab. Click Import. Select the source file and table, and click OK.

For more information about copying or importing fields and tables, see Help.
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Creating custom functions
Use the Custom Functions feature to create custom functions that can be reused anywhere in a
database file and copied or imported to other FileMaker Pro files. Once formulas are written for
the function, they don’t have to be rewritten to be applied to other fields or used in other scripts.
You can maintain and edit custom functions and the formulas they contain in one central location.
Any change made to the custom function will be copied to all instances where that custom function
has been used.
To create a custom function:
1. Choose File menu > Manage > Custom Functions.
2. In the Manage Custom Functions dialog box, click New.
View list (opened)

Parameters
list

Function
list

Formula box

Your custom parameters
appear in this space
Edit Custom Function dialog box

3. In the Edit Custom Function dialog box, type a name for the function and build a formula.
4. Click OK.
For more information about creating custom functions, see Help.
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About custom menus
With FileMaker Pro Advanced, you can create custom menus, menu items, and menu sets for
your database solutions. You can:

1
1
1
1

create a menu or edit an existing menu
duplicate or delete a menu
add, duplicate, or delete menu items
specify menu item properties, such as display title, shortcut, and action.
Menu set for this layout

Menu bar
Menu display title

Submenu

Menu

Separator

Menu item

Custom menu terminology

You can customize menus by:

1 editing a copy of a standard FileMaker menu. Use this method to make minor changes to
existing menus, for example, to modify the properties of a few menu items.

1 starting with an empty menu. Use this method to make significant changes to menus, for
example, to add menus and change menu item properties.
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Creating custom menus
To create a custom menu:
1. Choose File menu > Manage > Custom Menus > Custom Menus tab.
You see the Manage Custom Menus dialog box.

2. If FileMaker Pro Advanced includes menus that do not exist in this file, click Update to add
missing menus to the file.
3. Click Create.
4. In the Create Custom Menu dialog box, do one of the following, then click OK:

1 Click Start with an empty menu.
1 Click Start with a standard FileMaker menu, then select a menu from the list.
The Edit Custom Menu dialog box appears.
5. In the Edit Custom Menu dialog box, specify a custom menu name, a comment that describes
the menu (optional), the menu title that you want to display in the menu bar, conditions under
which the menu should be installed or not installed, and the FileMaker Pro modes in which the
menu should appear. See “Creating custom menu items” for information on specifying a
platform for a custom menu.
6. Create custom menu items, as described in the following section.

Creating custom menu items
After you create a menu, you can create menu items. You can also create or edit menu items that
are copies of the Standard FileMaker menus. Menu items can be commands, submenus, or
separators. You can create a menu item that is based on a standard FileMaker command or you
can create a menu item that initially does not have an assigned command.
When you base a menu item on a FileMaker command, the menu item inherits all the properties
of that command. You can override properties (menu item name, keyboard shortcut, or action) to
customize the menu item.
When you create a menu item that does not have an assigned command, an <unknown> menu
item appears in the Menu Items list in the Edit Custom Menu dialog box. You can then customize
this menu item’s properties.
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To create a new menu item:
1. Choose File menu > Manage > Custom Menus > Custom Menus tab.
2. In the Manage Custom Menus dialog box, select the menu to which you want to add the menu
item, then click Edit.
3. In the Edit Custom Menu dialog box, specify which menu items are included in the menu:
To

Do this

Add a command

Click Create to add a new (<unknown>) menu item to the list. For Menu Item Type,
choose Command, then select Based on an existing command. In the Specify
FileMaker Command dialog box, choose a command, then click Select (Windows) or OK
(Mac OS).
A command determines the action or behavior of a menu item.

Add a submenu

Click Create to add an <unknown> menu item to the list. For Menu Item Type, choose
Submenu, click Specify, select a menu, and click Select.
Note You can add up to 100 menus to the menu bar. If you add a menu that includes
itself as a submenu, you may quickly reach the limit.

Add a separator line

Click Create to add an <unknown> menu item to the list. For Menu Item Type, choose
Separator.

Duplicate a menu item

Select a menu item from the list, then click Duplicate.

Delete a menu item

Select a menu item from the list, then click Delete.

Drag an arrow

up or down to change the order of the menu items in the list.
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To change the properties of a menu item:
1. Select a menu item from the Menu Items list and do one or more of the following:
To

Do this

Change a command for
a menu item

For Based on an existing command, click Specify, choose a different command, then
click Select (Windows) or OK (Mac OS).

Change a menu item
from one type to another

For Menu Item Type, choose a different type. (For example, you can change a separator
to a command.)

Change the name of a
menu item

Select Item Name and enter a new name.
To base the menu title on the result of a calculation, click Specify, then build a formula in
the Specify Calculation dialog box.
Windows: To specify an access key, type an ampersand (&) before the character you
want to use as the access key. For example, type &Open to display the Open menu item
with the letter “O” as the access key.

Define a keyboard
shortcut for a menu item

Select Keyboard Shortcut. In the Specify Shortcut dialog box, type a key combination,
then click OK. Keyboard shortcuts appear next to menu items in the Menu Items list. For
more information about keyboard shortcuts, see Help.

Perform a script or script
step when a user
selects a menu item

Select Action. In the Specify Script Step dialog box, select a step and specify options as
necessary, then click OK.
Note To affect the behavior of a currently running script (for example, to halt, exit,
resume, or pause the script) use the Perform Script script step.
For more information about scripts and script steps, see Help.

Change a script or script
step

For Action, click Specify, modify the script definition, then click OK.

Install menu items
based on conditions you
specify

For Install when, specify a calculation that results in a Boolean value.
If the calculation evaluates true or non-zero, the menu item is installed.
For example, for the menu item to appear when the file is opened in Windows, enter:
If ( Abs(Get( SystemPlatform )) = 2; 1; 0 )
When the calculation evaluates false or zero, the menu item is not installed.
For example, for the menu item to appear when the file is opened in Mac OS, enter:
If ( Abs(Get( SystemPlatform )) = 1; 1; 0 )
To ensure a menu item is always installed, for Install when, enter 1.

2. Click OK.

Creating custom menu sets
Custom menu sets are collections of menus that appear in the FileMaker Pro application menu
bar. You can create custom menu sets to include only the menus you require. After you create
menu sets, you can:

1
1
1
1

specify menu sets for individual layouts
create scripts that change menu sets
change the default menu set in a solution file’s menu bar
switch menu sets temporarily using the FileMaker Pro Advanced Tools menu

To create or edit menu sets:
1. Choose File menu > Manage > Custom Menus > Custom Menu Sets tab.
2. Click Create.
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3. In the Edit Custom Menu Set dialog box, click Add to specify which menus to include in the menu
set.
To:

Do this:

Add a menu to this menu set

Click Add, do one of the following in the Select Menu dialog
box, then click Select:
1 Choose a menu from the list.

1 Click + to create a new menu. For more information, see
“Creating custom menus” on page 21.

1 Click – to remove a custom menu in the Select Menu
dialog box. Default FileMaker Pro menus shown in
brackets [ ] in the Select Menu dialog box cannot be
removed from the list.

Tip You can Shift-click or Ctrl-click (Windows) or Commandclick (Mac OS) additional menus to add multiple menus to
the menu set.
Change the properties of a menu in this menu set

Select the menu, then click Edit. For more information, see
“Creating custom menu items” on page 21.

Remove a menu from this menu set

Select the menu, then click Remove.

4. Click OK to return to the Manage Custom Menus dialog box.
5. To change the default menu set for this file, select Default menu set for this file and click OK.
You see the new menu set in FileMaker Pro. For more information about creating, installing,
and testing custom menu sets, see Help.

Using plug-ins to extend FileMaker Pro
If you are a C or C++ programmer and you are familiar with calculations in FileMaker Pro and
FileMaker Pro Advanced, you can create plug-ins that extend the feature set of the FileMaker
application. For example, plug-ins can take advantage of recursion and looping or hook into other
programming interfaces. For more information, see Help.

Chapter 4
Debugging and analyzing files
The FileMaker Pro Advanced features explained in this chapter are:

1 the Script Debugger for systematic testing and debugging of FileMaker scripts
1 the Disable script step feature for testing portions of a script
1 the Database Design Report feature for publishing comprehensive documentation on database
schema and options

1 the Data Viewer for monitoring fields, variables, and calculations
Note See Help for detailed, comprehensive information and step-by-step procedures for using
FileMaker Pro Advanced.

Debugging scripts
With FileMaker Pro Advanced, you can use the Script Debugger to:

1
1
1
1
1
1
1
1
1
1
1

debug scripts that are run from the Scripts menu or keyboard shortcuts
debug startup scripts (the Script Debugger menu is enabled even if there are no open files)
debug a script activated by a script trigger, button, or custom menu
step through scripts one step at a time
view subscripts as you step through scripts
set or clear breakpoints in a script
monitor fields, variables, and calculations
disable script steps
debug restricted-access scripts
pause a script when script errors are encountered
click a script error number to open a Help topic

1 temporarily disable or enable script triggers while you work in the Script Debugger
To run scripts in debug mode:
1. Select Tools menu > Script Debugger.
The Script Debugger dialog box opens.
2. Run your script.
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You can view sub-scripts when you step through scripts in the Script Debugger. For example, if
Script A calls Script B, which then calls Script C, you can view the steps in all three scripts.
The Script Debugger recognizes the privileges attached to each script. A script will only appear in
the Script Debugger if you have editing privileges for the script and the access privileges for the
script are set to Modifiable. You can click Authenticate/Deauthenticate script
to log in and edit
script steps in restricted-access scripts.
In the Script Debugger window you can select more than one step from the step list, enabling you
to place simultaneous multiple breakpoints on steps. If multiple steps are selected, the Set Next
Step button is disabled.
Notes

1 You can’t set breakpoints on script steps called by buttons or custom menus.
1 When you use the Script Debugger to step through enabled scripts activated by a script trigger,

you can’t interact with the document windows, move between fields or records, change the
data, close the window, or quit. This blocking of interaction only occurs when a script is triggered
via some action. When you are debugging a script that is not activated by a script trigger, you
can interact normally with the document windows, fields, and records. For more information
about using script triggers, see Help.

Tip To enable the Script Debugger from the Manage Scripts dialog box, press Shift and click the
Perform
button. To disable the Script Debugger, press Ctrl (Windows) or Command (Mac OS)
and click the Perform button.

Disabling script steps
You can disable and enable script steps to test portions of a script. When you run a script, disabled
script steps are skipped.
To disable script steps:
1. Choose Scripts menu > Manage Scripts.
Or, choose File menu > Manage > Scripts.
2. In the Manage Scripts dialog box, double-click the script name.
Or, click the Edit

button in the Script Debugger dialog box.

3. In the Edit Script dialog box, select one or more script steps, then click Disable or Enable.
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Disabling and enabling script triggers
You can temporarily disable and enable script triggers while you work in the Script Debugger. You
must have Full Access privileges to disable script triggers. Script triggers are enabled by default.
1. Select Tools menu > Script Debugger.
2. To disable all script triggers in a file, click
Disable Script Triggers.
3. To enable all script triggers, click
Enable Script Triggers.

or choose Tools menu > Debugging Controls >

or choose Tools menu > Debugging Controls >

When you close the Script Debugger, all disabled script triggers are enabled.
For more information about debugging scripts, see Help.

Using the Data Viewer
You can use the Data Viewer to monitor expressions like field values, local and global variables,
and calculations. You can monitor these expressions while running scripts or while testing them in
the Script Debugger.
The Current tab shows:

1 fields used by the currently running script whether they are referenced directly in the script or
indirectly in calculations

1 local variables used by the currently running script
1 global variables independent of any script
The Watch tab monitors expressions. You can enter expressions, one per row, in the Data Viewer.
When you use the Data Viewer with the Script Debugger, the Watch tab displays expressions from
paused scripts letting you see how data changes as you step though a script. Expressions remain
in the Watch tab until you manually delete them.
Monitoring the currently running script
1. Choose Tools menu > Data Viewer, or click the Open/Close Data Viewer
Script Debugger window.
2. Click the Current tab.
Click to view
restricted access
expressions
Click a column
heading to sort

button in the
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3. Perform the following tasks in the Current tab:
To

Do this

Edit or copy local or global variables

Double-click a variable in the list.

Sort fields and variable in the list

Click a column heading.
Items in the list are grouped by type, then sorted in this order: fields, global
variables, local variables.

Add an expression to the Watch list

Click Add to Watch.
FileMaker Pro switches to the Watch tab where the expression appears.

View restricted-access expressions

Click , then log into an account that has full access privileges.
Note If you log in to edit restricted-access scripts in the Script Debugger, your
access privileges also apply to the Data Viewer. If you log in via the Data Viewer,
your access privileges also apply to the Script Debugger. In either case, your
editing privileges last until you close the Script Debugger or the Data Viewer.

Monitoring expressions
1. In the Data Viewer, click the Watch tab.

Drag an arrow up or
down to change the
order
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2. Perform the following tasks:

1 To add an expression, click

.

In the Edit Expression dialog box, build an expression, then click Monitor to add the expression
to the Data Viewer.
Select mathematical and
text operators

Select comparison and
logical operators
Choose the way
functions are listed in
this dialog box

Table name
Select
functions

Choose field
references

Formula box

Results of
the
expression
Evaluate the contents of
the expression

Add the
expression to the
Data Viewer

1 To edit an expression, double-click the expression in the list or select an expression and click
. Click Evaluate Now to display the results of the expression or click Monitor to add the
expression to the Watch list.

1 To duplicate expressions, select one or more expressions, then click .
1 To delete expressions, select one or more expressions, then click .
1 To update the values for calculations displayed in the list, click Refresh Values.
Values update as you scroll through the list.

For more information about using the Data Viewer, see Help.

Using the Database Design Report
Use the Database Design Report (DDR) feature to document the schema of your database and
publish it to an HTML or XML file. You can choose which elements and database tables in the
database you want to report. The HTML version of the report is hyperlinked and you can view or
print it in a Javascript-enabled web browser.
With the Database Design Report feature you can:

1 examine a textual representation of your database schema
1 gather statistics on the structure of your database
1 use the information in the report to recreate the structure of your database if you lose the
original database files

1 troubleshoot missing references, broken relationships, calculations, and more
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To create a Database Design Report:
1. Open all database files for which you want to produce a Database Design Report.
You must have full access privileges for any file for which you want to produce a Database
Design Report and the file must be open in FileMaker Pro Advanced. You can run a Database
Design Report on local or remote files.
2. Choose Tools menu > Database Design Report.
3. In the Available Files list, clear any files that you want to exclude from the report by clearing
the checkbox associated with the file.
4. If there are any files that contain tables that you want to exclude from the report, select the file
in addition to the checkbox in the Available Files list.
The tables in the file appear in the Include fields from tables in selected file list. You can then
deselect any table in the list.
By default, all tables in all selected files are reported.
5. Clear elements that you want to exclude from the report.
By default, all elements in all selected files are reported. Each selected element, if present, will
be reported on for each selected file.
6. If you prefer to publish the report in XML format instead of the default HTML, select XML in the
Report Format section.
7. If you do not want the report to automatically open when done, clear the checkbox for this option
in the File Handling section.
8. Click Create.
For more information about using the Database Design Report, see Help.

Appendix A
Feature comparison of the runtime application
with FileMaker Pro
When you double-click the FileMaker Pro application icon to start the application you can create
a new database or choose a file to open. When you start a FileMaker Pro runtime application, the
primary bound database file opens automatically.
Other key differences between the runtime application and FileMaker Pro include the following:

1 All the database design features have been removed or hidden in the runtime application.
This includes Layout mode and commands on the Manage submenu.

1 Custom functions and custom menus created with FileMaker Pro Advanced will work in the
runtime application, although users of the runtime application cannot modify or create new
custom functions or custom menus.

1 Some other menu commands have been removed from the runtime application.
For example, you can’t use the runtime application to create, open, or close a database. (Bound
runtime database files must contain a custom button or script to close or open other files. There
is no close command on a runtime database window.)

1 FileMaker Pro Help is not available in the runtime application. However, you can use the
custom menu feature to display customized Help text that you create.

1 Plug-ins can be enabled in the Preferences dialog box. The Allow Solutions to Install Files
option in the Plug-Ins preferences allows plug-in updates to install automatically. For more
information, see Help.

1 Although the XML Data filter appears as an option for the Convert File script step, you can’t
convert XML files using this script step in a runtime application.

1 FileMaker Pro File Sharing, serving a database on the web, or communicating with a Java

applet requires FileMaker Pro or FileMaker Pro Advanced. You can, however, use a compatible
version of FileMaker Server to serve runtime solution files.

1
1
1
1

Apple events are supported in runtime applications.
Runtime applications cannot be shared over a network.
Runtime applications do not include the ability to Save/Send Records as Adobe PDF files.
FileMaker Pro Advanced features are not available in the runtime application.
A runtime database can, however, be opened in either FileMaker Pro or FileMaker Pro
Advanced. The full functionality of these applications will be enabled, except if full access
privileges have been removed.

1 Runtime applications don’t support external SQL data sources (ESS), ODBC import, or the
Execute SQL script step.

1 Charts are not supported in runtime solutions.
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Application and document preferences
In the runtime application, some options are not available on the General tab of the Preferences
dialog box.
General preferences
in a runtime
application
(Mac OS X)

The Layout tab is not included in the Preferences dialog box for the runtime application.
General preferences
in a runtime
application
(Windows)

The File Options dialog box in the runtime application displays only the Spelling tab.
File options dialog
box in a runtime
application
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Menu command comparison
The following tables show the menu commands that are available in FileMaker Pro (Pro) and in
the runtime application (RT).
File Menu command

Windows Pro

Windows RT

Mac OS X Pro

Mac OS X RT

New Database

1

1

New From

1

1

Open

1

1

Open Remote

1

1

Open Recent

1

1

Open Favorite

1

1

Close

1

1

Manage

1

1

Sharing

1

1

File Options

1

1

1

1

Change Password

1

1

1

1

Print Setup

1

1
1

1

Page Setup
Print

1

1

1

1

Import Records

1

1

1

1

Export Records

1

1

1

1

Save/Send Records As

1

1

1

1

Send

1

2

1

2

Save a Copy As

1

1

1

1

Recover

1

3

1

4

Exit

1

1

1. You can’t Save/Send Records as PDFs or Snapshot Links. However, users can print the current record to PDF by choosing File menu > Print.
2. You can’t Send a Link to Database
3. Press Ctrl+Shift
4. Press Option+3

Edit Menu command

Windows Pro

Windows RT

Mac OS X Pro

Mac OS X RT

Undo/Can’t Undo

1

1

1

1

Redo

1

1

1

1

Cut

1

1

1

1

Copy
(Copy All Records)

1

1

1

1
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Edit Menu command

Windows Pro
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Windows RT

Mac OS X Pro

Mac OS X RT

Paste

1

1

1

1

Paste Text Only

1

1

1

1

Clear

1

1

1

1

Duplicate

1

Select All
(Select All Records)

1

1

1

1

Find/Replace

1

1

1

1

1

1

1

1

1

Spelling

1

1

Object

1

1

Export Field Contents

1

1

Preferences

1

1

1. Disabled if a script is paused or a scripting window is in the foreground

View Menu command

Windows Pro

Windows RT

Mac OS X Pro

Mac OS X RT

Browse Mode

1

1

1

1

Find Mode

1

1

1

1

Layout Mode

1

Preview Mode

1

1

1

1

Go to Layout

1

1

1

1

View as Form

1

1

1

1

View as List

1

1

1

1

View as Table

1

1

1

1

Status Toolbar

1

1

1

1

Customize Status Toolbar

1

1

1

1

Formatting Bar

1

1

1

1

Ruler

1

1

1

1

Zoom In

1

1

1

1

Zoom Out

1

1

1

1

Insert Menu command

Windows Pro

1

Windows RT

Mac OS X Pro

Mac OS X RT

Picture

1

1

1

1

QuickTime

1

1

1

1

Audio/Video

1

1

1

1

Sound

1

1

1

1

PDF

1

1

1

1

File

1

1

1

1

Appendix A | Feature comparison of the runtime application with FileMaker Pro

Insert Menu command

Windows Pro
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Windows RT

Mac OS X Pro

Mac OS X RT

Current Date

1

1

1

1

Current Time

1

1

1

1

Current User Name

1

1

1

1

From Index

1

1

1

1

From Last Visited Record

1

1

1

1

Format Menu command

Windows Pro

Windows RT

Mac OS X Pro

Mac OS X RT

Font

1

1

1

1

Size

1

1

1

1

Style

1

1

1

1

Align Text

1

1

1

1

Line Spacing

1

1

1

1

Text Color

1

1

1

1

Records Menu command

Windows Pro

Windows RT

Mac OS X Pro

Mac OS X RT

New Record

1

1

1

1

Duplicate Record

1

1

1

1

Delete Record

1

1

1

1

Delete Found Records/Delete All Records

1

1

1

1

Go to Record

1

1

1

1

Refresh Window

1

1

1

1

Show All Records

1

1

1

1

Show Omitted Only

1

1

1

1

Omit Record

1

1

1

1

Omit Multiple

1

1

1

1

Modify Last Find

1

1

1

1

Saved Finds

1

1

1

1

Sort Records

1

1

1

1

Unsort

1

1

1

1

Replace Field Contents

1

1

1

1

Relookup Field Contents

1

1

1

1

Revert Record

1

1

1

1
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Requests Menu command (Find mode)

Windows Pro

36

Windows RT

Mac OS X Pro

Mac OS X RT

Add New Request

1

1

1

1

Duplicate Request

1

1

1

1

Delete Request

1

1

1

1

Go to Request

1

1

1

1

Show All Records

1

1

1

1

Perform Find

1

1

1

1

Constrain Found Set

1

1

1

1

Extend Found Set

1

1

1

1

Revert Request

1

1

1

1

Scripts Menu command

Windows Pro

Windows RT

Mac OS X Pro

Manage Scripts

1

1

Save Script

1

1

Save All Scripts

1

1

Revert Script

1

1

<Script names>

1

1

1

Mac OS X RT

1

Note The Save Script, Save All Scripts, and Revert Script menu commands only appear when
the Manage Scripts or Edit Script dialog box is active.

Window Menu command

Windows Pro

Windows RT

Mac OS X Pro

Mac OS X RT

New Window

1

1

1

1

Show Window

1

1

1

1

Hide Window

1

1

1

1

Minimize Window

1

1

1

1

Tile Horizontally

1

1

1

1

Tile Vertically

1

1

1

1

Cascade Windows

1

1

1

1

Arrange Icons

1

1
1

1

1

1

Bring All To Front
<Names of open files>

1

1
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Help Menu command

Windows Pro

37

Windows RT

Mac OS X Pro

FileMaker Pro Help

1

1

Keyboard Shortcuts

1

1

Quick Start Screen

1

1

Resource Center

1

1

Product Documentation

1

1

Consultants and Solutions

1

1

Provide FileMaker Feedback

1

1

Check for Updates

1

1

Register FileMaker Pro

1

1

FileMaker Forum

1

1

Service and Support

1

1

About FileMaker Pro (or About FileMaker Pro
Advanced)

1

Mac OS X RT

1

About FileMaker Pro Runtime
(Displays if no custom About script is specified)

1

1

About <runtime solution>
(Displays if custom About script is specified)

1

1

<Runtime solution Help script name>
(Displays if custom Help script is specified)

1

1

1

See Application Menu command table

Application Menu command (Mac OS X only)
About FileMaker Pro

Pro

RT

1

About FileMaker Pro Runtime
(Displays if no custom About script is specified)

1

About <runtime solution>
(Displays if custom About script is specified)

1

Preferences

1

1

Services

1

1

Hide FileMaker Pro

1
1

Hide <runtime solution>
Hide Others

1

1

Show All

1

1

Quit FileMaker Pro

1

Quit <runtime solution>

1
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Ignored script steps
Because some features have been removed from the runtime application, the following script
steps are ignored by the runtime application:

1
1
1
1
1
1
1
1
1

Open Manage Database

1
1
1
1
1
1

New File

Open Manage Value List
Open Manage Data Sources
Open Manage Scripts
Open Manage Layouts
Open Manage Containers
Open Sharing
Open Help
Set Multi-User
Open File Options (partially available; Spell checking tab will open)
Open Remote
Execute SQL
Save Records As PDF
Save Records As Snapshot Link

Note Open File returns an error if the specified file has not been bound to the runtime application. A
runtime solution can only perform an external script if the external file is bound to the runtime solution.

Stored registry settings or preferences
Windows registry settings
FileMaker Pro stores its registry settings at
HKEY_CURRENT_USER\Software\FileMaker\FileMaker Pro\12.0

FileMaker Pro Advanced stores its registry settings at
HKEY_CURRENT_USER\Software\FileMaker\FileMaker Pro\12.0A

The runtime application stores its registry settings at
HKEY_CURRENT_USER\Software\FileMaker\<solution name>\12.0

Note The filename extension for the runtime database files is registered at HKEY_CLASSES_ROOT.
Mac OS X preferences
FileMaker Pro stores its preferences settings in
com.filemaker.client.pro.plist

FileMaker Pro Advanced stores its preferences settings in
com.filemaker.client.advanced.plist

The runtime application stores its preferences in
com.filemaker.client.runtime.<Solution name>.plist

Index
A
About layout
described 6
required contents of 7
access privileges 7, 18
accounts and privileges 7, 18
removing Admin access 9
Admin access
removing from files 9
removing from Kiosk solutions 17
Apple events in runtime applications 31
authenticating scripts 26
auxiliary files
problems with double-clicking icons 12
updating 16

B
backups 15
binding key
about 11
updating runtime database solutions 15
binding runtime solutions 11

C
commands, menu
available in runtime applications 33
compression utilities for runtime databases 14
converting files from previous versions 10
copying field or table schemas 18
cross-platform solutions 11
custom functions, creating 19
custom menus
about 20
creating 21
menu items 21
menu sets 23
specifying platform 23

D
data sources
updating 15
updating automatically 9
Data Viewer 27
Database Design Reports 29
database schemas
copying or importing 18
in Database Design Report 29
database statistics 29
database structure, recreating 29
DDR. See Database Design Reports
debugging scripts 25
delay, splash screen 11

Developer Utilities
about 8
creating runtime solutions 9
disabling script steps 26
disabling script triggers 27
distributing runtime database solutions
about 12
distributing updates 15
terms and conditions 6
documenting
Database Design Reports 29
runtime solutions 14
Dynamic Link Libraries (DLLs) 12

E
Edit menu commands available in runtime applications 33
error codes, viewing from Script Debugger 25
error log 9
Execute SQL script step 38
expressions, monitoring 27
extensions, filename. See filename extensions

F
fields
copying schema 18
monitoring 27
File menu commands available in runtime applications 33
File Options available in runtime application 32
file references. See data sources
FileMaker Developer. See FileMaker Pro Advanced
FileMaker Pro Advanced
documentation 5
license agreement 6
upgrading from earlier versions 10
FileMaker Pro, menus available 33
FileMaker Server 14, 31
filename extensions
for database files 9
for runtime solutions 11
files
compressing runtime 14
converting 10
removing Admin access 9
renaming 8
updating 9
folder structure, solution 12
fonts
not on user’s system 13
Format menu commands available in runtime applications 35
formulas
for custom functions 19
monitoring 27

40

functions
custom 19
monitoring in formulas 29

H
Help
menu commands available in runtime applications 37
Help layout 14
HTML format for Database Design Reports 29

I
icons for runtime solutions 12
Insert menu commands available in runtime applications 34
installation instructions 6
installers for runtime databases 13
InstallShield 13
Internet
databases on 6
runtime applications on 31

J
JDBC, FileMaker as data source 6

K
keyboard shortcuts in custom menu items 23
Kiosk solutions, creating 16

L
Layout mode commands, unavailable in runtime
applications 31
legal requirements 6
license agreement 6
Logfile.txt 9
logo, adding to runtime solution 11

M
Mac OS X
runtime application package 13
stored preferences 38
MacInstallerBuilder 13
Manage Scripts 26
Manage submenu, unavailable in runtime applications 31
menu commands, available in runtime applications 33
menu separators 22
menu sets, creating 23
messages, error log 9
Microsoft Windows, stored registry settings 38
MindVision Installer VISE 13
multiple tables per database file 10

N
naming runtime database solutions 11
networks, sharing solutions on 14

new features 6
New File script step 38

O
ODBC, FileMaker as data source 6
Open File Options script step 38
Open File script step 38
Open Help script step 38
Open Manage Containers 38
Open Manage Data Sources script step 38
Open Manage Database script step 38
Open Manage Layouts script step 38
Open Manage Scripts script step 38
Open Manage Value List script step 38
Open Remote script step 38
Open Sharing script step 38
opening files in runtime applications 31

P
passwords, required warning in About layout 7
PDF documentation 6
platform, specifying for custom menus 23
plug-ins
in runtime applications 31
preferences available in runtime application 32
primary file
connecting auxiliary files 10
specifying 8
updating 16
Project Folder 8, 11

R
Records menu commands available in runtime applications 35
recovering damaged runtime files 14
registry, stored settings 38
renaming files 8
reports, database 29
runtime applications
available menu commands 33
compared to FileMaker Pro 31
enabling plug-ins in 31
icon 12
ignored script steps 38
stored Mac OS X preferences 38
stored Windows registry settings 38
runtime database solutions
About layout requirements 7, 14
binding files 11
converting 10
creating 8, 9
documenting 12
preparing files 9
recovering damaged files 14
starting 12
updating 15
upgrading 10

41

S

V

Save Records as PDF script step 38
Save Records as Snapshot Link script step 38
schemas, database
copying or importing 18
documenting 29
Script Debugger
described 25
with script triggers 26
script triggers, debugging 26
scripts
authenticating 26
debugging 25
disabling script steps 26
disabling script triggers 27
steps ignored by runtime applications 38
unlocking 26
Scripts menu
commands available in runtime applications 36
separators, menu item 22
Set Multi-User script step 38
settings file 9
shortcuts, keyboard. See keyboard shortcuts
solution file
icon 12
problems with double-clicking icon 12
splash screen in runtime solutions
closing 11
startup 10
starting runtime solutions 12
statistics, database 29
structure, database 29

variables, monitoring 27
View menu commands available in runtime applications 34

T
tables, database
copying or importing schema 18
excluding from Database Design Report 30
multiple per file 10
testing
database solutions 15
scripts 25
touch screen 16
troubleshooting
calculations 27
fields 27
Script Debugger 25
using Database Design Reports 29
variables 27
tutorial, FileMaker Pro 6

U
unlocking scripts 26
updates
to runtime solutions 15
upgrading runtime databases 10
user interaction with database solution 10

W
web browser users 6
web viewer 14
Window menu commands available in runtime applications 36
Windows runtime application package 13

X
XML
format for Database Design Reports 29
output grammar for DDR 6

